Bug 1287049 - Docker search does not work on default settings.
Docker search does not work on default settings.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 06:57 EST by Kazuhisa Hara
Modified: 2015-12-10 20:50 EST (History)
11 users (show)

See Also:
Fixed In Version: docker-1.9.1-4.git6ec29ef.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 20:50:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kazuhisa Hara 2015-12-01 06:57:06 EST
Description of problem:
Docker search does not work on default settings.

Version-Release number of selected component (if applicable):
$ rpm -qa |grep docker
docker-1.9.1-2.git78bc3ea.fc23.x86_64
cockpit-docker-0.83-1.fc23.x86_64
docker-selinux-1.9.1-2.git78bc3ea.fc23.x86_64

$ sudo docker version 
Client:
 Version:         1.9.1-fc23
 API version:     1.21
 Package version: docker-1.9.1-2.git78bc3ea.fc23.x86_64
 Go version:      go1.5.1
 Git commit:      f7c1d52-dirty
 Built:           Fri Nov 20 21:07:14 UTC 2015
 OS/Arch:         linux/amd64

Server:
 Version:         1.9.1-fc23
 API version:     1.21
 Package version: docker-1.9.1-2.git78bc3ea.fc23.x86_64
 Go version:      go1.5.1
 Git commit:      f7c1d52-dirty
 Built:           Fri Nov 20 21:07:14 UTC 2015
 OS/Arch:         linux/amd64


How reproducible:
100%


Steps to Reproduce:
1. Fedora23(x86_64) clean install
2. sudo dnf install docker
3. sudo docker search fedora
   and
4. sudo docker search docker.io/fedora

Actual results:
$ sudo docker search fedora
Error response from daemon: invalid registry endpoint https:////v0/: unable to ping registry endpoint https:////v0/
v2 ping attempt failed with error: Get https:////v2/: http: no Host in request URL
 v1 ping attempt failed with error: Get https:////v1/_ping: http: no Host in request URL. If this private registry supports only HTTP or HTTPS with an unknown CA certificate, please add `--insecure-registry ` to the daemon's arguments. In the case of HTTPS, if you have access to the registry's CA certificate, no need for the flag; simply place the CA certificate at /etc/docker/certs.d//ca.crt

$ sudo docker search docker.io/fedora
INDEX       NAME                                       DESCRIPTION                                     STARS     OFFICIAL   AUTOMATED
docker.io   docker.io/fedora                           Official Docker builds of Fedora                253       [OK]       
~~ snip ~~


Expected results:
docker.io should be searched even if we do not explicitly specify the registry.

Additional info:
https://docs.docker.com/engine/userguide/dockerrepos/#searching-for-images
Comment 1 Michal Minar 2015-12-02 05:01:05 EST
This is fixed in recent fedora-1.9 branch. Lokesh, could you please rebuild?

docker-1.9.1-3.git64eb95e.fc22 is working fine because it contains https://github.com/rhatdan/docker/commit/f4b87f52db74cf8f88a87fe61ba74cd8395edb69
Comment 2 Fedora Update System 2015-12-09 04:31:36 EST
docker-1.9.1-4.git6ec29ef.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-5917f166c6
Comment 3 Fedora Update System 2015-12-09 23:55:37 EST
docker-1.9.1-4.git6ec29ef.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update docker'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-5917f166c6
Comment 4 Fedora Update System 2015-12-10 20:50:24 EST
docker-1.9.1-4.git6ec29ef.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.