Bug 1287059 - fence_rhevm can only work as RHEV admin user not a regular user (that requires "Filter: true http header)
fence_rhevm can only work as RHEV admin user not a regular user (that require...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fence-agents (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: Marek Grac
cluster-qe@redhat.com
:
: 1391361 (view as bug list)
Depends On:
Blocks: 1296673
  Show dependency treegraph
 
Reported: 2015-12-01 07:08 EST by David Jaša
Modified: 2017-03-21 09:54 EDT (History)
8 users (show)

See Also:
Fixed In Version: fence-agents-4.0.11-47.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:48:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Combined patches from upstream (2.37 KB, application/mbox)
2016-02-18 05:24 EST, Oyvind Albrigtsen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2975451 None None None 2017-03-21 09:54 EDT

  None (edit)
Description David Jaša 2015-12-01 07:08:13 EST
Description of problem:
fence_rhevm doesn't provide any option that would translate to addition of "filter: true" http header, that is required to access the VM as a regular RHEV user.

Version-Release number of selected component (if applicable):
fence-agents-rhevm-4.0.11-27.el7

How reproducible:
always

Steps to Reproduce:
1. have a user account in RHEV and a VM with UserVmManager permission on it for that user (this permissions gives full control of the VM to the user without having any rights on RHEV itself)
2. try to use fence_rhevm to query status of the VM
3.

Actual results:
"Failed: unable to obtain correct plug status or plug is not available" - because this user if banned from API unless "Filter: true" header is set

Expected results:
it's possible to tell fence_rhevm to log in as a user

Additional info:
Comment 2 Oyvind Albrigtsen 2016-02-18 05:24 EST
Created attachment 1128181 [details]
Combined patches from upstream
Comment 3 Mike McCune 2016-03-28 19:04:30 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Oyvind Albrigtsen 2016-08-31 06:57:28 EDT
New build with the following patch that solves the issue with RHEV4:
https://github.com/ClusterLabs/fence-agents/pull/71/commits/786f5e1d5af984a958dc5502a8d065a24cb66970
Comment 11 Marek Grac 2016-11-03 04:54:25 EDT
*** Bug 1391361 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2016-11-04 00:48:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2373.html

Note You need to log in before you can comment on or make changes to this bug.