Bug 1287078 - Camel Hawt.io console hangs in Firefox with karaf-camel-amq quickstart
Camel Hawt.io console hangs in Firefox with karaf-camel-amq quickstart
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: stlewis@redhat.com
Marek Schmidt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 08:15 EST by Marek Schmidt
Modified: 2016-09-07 17:13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Fedora 22, Firefox 42, Fuse Integration Services on OpenShift 1.0 CR1 A-MQ on OpenShift 6.2 CR1
Last Closed: 2016-09-07 17:13:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Schmidt 2015-12-01 08:15:20 EST
Description of problem:

After deploying of the Karaf Amq Quickstart

https://github.com/fabric8io/ipaas-quickstarts/tree/redhat/quickstart/karaf/camel-amq

Using the 'connect' button in the OpenShift Console to open the karaf-camel-amq pod in Firefox, the view hangs.

Version-Release number of selected component (if applicable):

oc v3.1.0.4-3-ga6353c7
kubernetes v1.1.0-origin-1107-g4c8e6f4

Using Karaf image

rcm-img-docker01.build.eng.bos.redhat.com:5001/jboss-fuse-6/fis-karaf-openshift:1.0-3

Using A-MQ image

rcm-img-docker01.build.eng.bos.redhat.com:5001/jboss-amq-6/amq62-openshift:1.2-6


How reproducible:
Always


Steps to Reproduce:
1. Deploy the quickstart from  
https://github.com/fabric8io/ipaas-quickstarts/tree/redhat/quickstart/karaf/camel-amq 

(change the mentioned images to use the current RCM images mentioned above)

2. Open OpenShift console, locate the karaf-camel-amq Pod, use the "Connect" link to connect to the container Hawt.io

3. Notice the console appears to be hanging

Actual results:

Console is stuck in an empty list of camel routes

Expected results:

3 routes should immediately appear.

Additional info:

This seems to work properly with Google Chrome. Also, and more interestingly, when the view is stuck in Firefox, opening the same view in Chrome make the Firefox view unstuck... pretty hardcore stuff...
Comment 1 stlewis@redhat.com 2015-12-01 11:56:38 EST
Just to clarify, if you click on another item in the JMX tree and then back on "Routes" do they show up then?  Am seeing here on Firefox only that a fair number of views don't show up on the initial page load, whereas they do on Google Chrome and am wondering if this is actually the same general problem.
Comment 2 stlewis@redhat.com 2015-12-01 14:20:50 EST
Just pushed this fix which fixes the issue I've been seeing, which sounds like the same issue:

https://github.com/hawtio/hawtio-jmx/commit/89bb9eb1a96f29d99f4b9335ae08f062927ae3de

Will pull this into a new openshift-jvm release after I've done a bit of layout work on a few pages.
Comment 3 Marek Schmidt 2015-12-02 14:50:00 EST
After reproducing this multiple times on two different instances:

* This does not seem to happen always after all. It seem to be more likely to happen with a slower master (on OS1 internal openstack rather than an OSE instance on bare metal) or when the master is under load (but I don't really have enough data to be sure)

* It is not possible to open another item in the JMX tree when the hang occurs, as the whole firefox tab seems to be blocked, so it seems more like some javascript infinite loop.
Comment 4 Jessica Forrester 2016-01-05 11:00:52 EST
Moving to low since Stan isn't able to reproduce this
Comment 5 stlewis@redhat.com 2016-01-29 13:06:55 EST
Have reproduced this and am currently investigating
Comment 6 stlewis@redhat.com 2016-01-29 16:45:24 EST
Tracked down a couple sync calls being made, reworked that.  There seems to be a general issue with that quickstart but maybe it's just my environment, in any case it's issues made it reliably reproduce for me :-)

Anyways, the related fixes are below, will get a PR to get this into openshift early next week after maybe getting another fix or two in.

hawtio-integration => https://github.com/hawtio/hawtio-integration/commit/72a2f0d15f77fa900dfe1ea79d7502a8d06ee386

hawtio-jmx => https://github.com/hawtio/hawtio-jmx/commit/aed2c1b61793ce499266902bde6b72c37279f9af

which went into this openshift-jvm version:

https://github.com/hawtio/openshift-jvm/commit/8c21a1dceb341fc6f3795b0d140c573dc0624b43
Comment 7 stlewis@redhat.com 2016-02-01 11:04:30 EST
PR => https://github.com/openshift/origin/pull/6938
Comment 8 Marek Schmidt 2016-02-17 06:38:09 EST
Verified on current 3.2 Puddle

(openshift-jvm Version: 1.0.42 Commit ID: d46658f96d3134f99b0b6073433d4366defaee0f )

Note You need to log in before you can comment on or make changes to this bug.