Bug 1287098 - unable to mount errors with vddk v5.5.5
unable to mount errors with vddk v5.5.5
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: cfme-future
Assigned To: Jerry Keselman
Satyajit Bulage
vsphere:vm:smartstate
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 08:56 EST by Dave Johnson
Modified: 2017-08-28 10:46 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-28 10:46:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2015-12-01 08:56:56 EST
Description of problem:
===================================
We started running into the following scanning issues when we moved to vddk v5.5.5 which I thought had checked out but apparently not.  This happened while chasing after bug 1267565.

"Unable to mount filesystem. Reason:[FFI::VixDiskLib::ApiWrapper#open (errcode=18000 - VIX_E_CANNOT_CONNECT_TO_HOST): Cannot connect to the host - [cfme-netapp2554-vs1] aziza-cfme-55010-dnd/aziza-cfme-55010-dnd.vmdk FFI::VixDiskLib::ApiWrapper#open (errcode=18000 - VIX_E_CANNOT_CONNECT_TO_HOST): Cannot connect to the host - [cfme-netapp2554-vs1] aziza-cfme-55010-dnd/aziza-cfme-55010-dnd_1.vmdk]"


Version-Release number of selected component (if applicable):
===================================
5.5.0.12


How reproducible:
========================
100%


Steps to Reproduce:
=========================
1.  install vddk v5.5.5
2.  configure for scanning
3.  scan


Actual results:
==================
unable to mount errors


Expected results:
==================
scanning success
Comment 2 Jerry Keselman 2015-12-01 09:49:52 EST
Can you tell me where you found the VDDK 5.5.5?  I just searched through all of the downloads on vmware.com, but logged in and logged out, and there are 78 dls, none of which are 5.5.5.  There is 5.5.4, and then 6.0.0, and there are 5.5 updates 1, 2, etc.

Thanks.
Comment 4 Jerry Keselman 2015-12-01 17:38:27 EST
I have reproduced this problem using your copy of the 5.5.5 VDDK and Mahwah infrastructure.  This appears to be an issue with this version of the VDDK.  It is interesting that I cannot find 5.5.5 on the vmware downloads page.
Should we consider documenting that this version of the VDDK is problematic?

Unfortunately earlier releases of the VDDK tagged the libraries with the point release and our code could exclude releases with issues, but there is no way to tell the working 5.5.4 version of the VDDK from the failing 5.5.5 one currently.
Comment 8 Satyajit Bulage 2016-05-04 09:23:22 EDT
This happens with vddk 5.5.4 as well against vSphere55.
Comment 11 Jerry Keselman 2017-04-06 17:19:29 EDT
Dave,  VDDK is now up to 6.5.  I have been able to run on 6.0, and 6.5 against vCenter 5.5, 6.0, and 6.5.  I'm not sure if you want to keep this particular BZ open any longer. Obviously the customer in question has upgraded to a newer than 5.5.5 version of the VDDK by this point - 16 months later.  The only thing we could possibly do is disallow all 5.5.x versions of the VDDK from being loaded, as stated previously.
Comment 12 Marianne Feifer 2017-05-17 11:57:47 EDT
I'm unclear as to why this BZ is still open.  Anyone??
Comment 16 Dave Johnson 2017-05-17 18:22:27 EDT
So my preference would be to add restrictions in ffi_vix-disk-lib and prevent any v5.5.x version of the vddk.   I assume that this is straightforward, a simple fix, and much more deliberate than relying on documentation to address the issue.  This is (partially) dependent on the assumption that a pretty error message is displayed at least in the logs to say as much but would be better if it was viewable in the UI under SSA tasks ui.  

With that said, I don't think we backport it but document it as a upcoming deprecation in 5.8 release notes and merge to 5.9 branch?

What do you think Jerry?
Comment 17 Jerry Keselman 2017-05-17 21:24:15 EDT
Dave this is certainly possible.  At the time this code path was developed the intent was to print a relevant message about the version being invalid in the log files.  We can test to make sure that is still what happens and fix it if the message isn't there anymore.  I agree that having the message show up in the UI would be better but knowing where the message is coming from (a separate process) I am not going to promise that.
So I'm sitting at home without a reference mapping CF release numbers to the ManageIQ release names - is 5.8 the current release that is supposed to come out at the end of May?  Or is that the follow-on?  If it is the soon to be released release this bug would have to be classified as a blocker.
Comment 19 Chris Pelland 2017-08-28 10:46:36 EDT
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.