Bug 1287102 - Quota-Max CPU/Memory by tagging group doesn't work
Quota-Max CPU/Memory by tagging group doesn't work
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.6.0
Assigned To: Tina Fitzgerald
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 09:02 EST by Taras Lehinevych
Modified: 2016-08-02 21:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 10:20:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Taras Lehinevych 2015-12-01 09:02:41 EST
Description of problem:
The quota max tagging for group doesn't work on version 5.5. 

Version-Release number of selected component (if applicable):
5.5.0.12

How reproducible:
ALWAYS on 5.5
Works fine on 5.4

Prerequisities:
A provider set up, supporting provisioning in CFME

Steps to Reproduce:
1. Go to Configure -> Configuration -> Access Control -> Groups
2. Choose EvmGroup-super_administrator, press Policy -> Editing My Company Tags for this group
3. Add the Quota-Max CPUs  = 2 or Quota-Max Memory = 2GB
4. Go to Virtual Machine, press Lifecycle -> Provision VMs
5. Choose template, fill in all necessary information (email, name of vm and etc)
6. On Hardware tab, choose the Memory (MB) > 2GB or Number of Sockets > 2 (values from step 3)
7. Press Submit and wait for request

Actual results:
Vm Provisioned Successfully 

Expected results:
Error message "Request denied due to the following quota limits:(Group Allocated vCPUs 0 + Requested 8 > Quota 2)" or "Request denied due to the following quota limits:(Group Allocated Memory 0.00GB + Requested 4.00GB > Quota 2.00GB)"

Additional info:
test_infra_quota (tests for this bz in cfme_tests)
Comment 2 Tina Fitzgerald 2015-12-01 11:29:16 EST
Hi Taras,

There's been a significant change in quota processing for 5.5 with the introduction of the new consolidated quota. 

General Quota Change Notes:

Old Quota:
Groups/users as the quota source.
Quota instance values specify max values for quota items.
Tags can be used to override instance max values.
Vm/Services had separate quota state machines.

New Quota:
Tenant is default source for quota. 
Has the ability to use groups/users with an automate method change.
Tenant quota values are not overridden by tag values.
Vm/Services use single common quota state machine

It looks like this came up as a result of automated testing. 
Should I close it as NOTABUG?

Let me know if you have any questions.

Thanks,
Tina
Comment 3 Taras Lehinevych 2015-12-02 06:42:57 EST
Hi Tina, 

Thanks you for response and detail information. 
Yes, you can close this bz.

Note You need to log in before you can comment on or make changes to this bug.