Bug 1287131 - Wdmd fail to start after an upgrade "other wdmd not cleanly stopped, shm_open error 17"
Wdmd fail to start after an upgrade "other wdmd not cleanly stopped, shm_open...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sanlock (Show other bugs)
7.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: David Teigland
Artyom
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 10:01 EST by Jan Kurik
Modified: 2016-03-31 17:54 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to a bug, when the wdmd service attempted to restart, it disabled the watchdog device on the system, which prevented the watchdog from resetting the system if the wdmd service failed before. With this update, vdmd no longer fails to start in the described situation.
Story Points: ---
Clone Of: 1278369
Environment:
Last Closed: 2016-03-31 17:54:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-12-01 10:01:41 EST
This bug has been copied from bug #1278369 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 4 Artyom 2016-01-28 09:28:57 EST
Verified on sanlock-3.2.4-2.el7_2.x86_64

1) Start with host RHEL7.1 - sanlock-3.2.2-2.el7.x86_64
2) Get two sanlock locks:
sanlock client status
daemon c094d046-98f8-4ee6-a714-bca06544be77.rose05.qa.
p -1 helper
p -1 listener
p -1 status
p 32347 
s c8b5968c-68e8-4ed6-b309-163fc9e148bb:1:/rhev/data-center/mnt/10.35.64.11\:_vol_RHEV_Virt_alukiano__HE__upgrade/c8b5968c-68e8-4ed6-b309-163fc9e148bb/dom_md/ids:0
s hosted-engine:1:/var/run/vdsm/storage/c8b5968c-68e8-4ed6-b309-163fc9e148bb/24ee7f20-f2eb-4734-9741-ead1eb66bcc2/b209bc7f-3154-430f-b9ef-0d3bd584e589:0
3) Update host to RHEL72 - sanlock-3.2.4-2.el7_2.x86_64
4) Check that sanlock and wdmd services up after update
Comment 6 errata-xmlrpc 2016-03-31 17:54:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0541.html

Note You need to log in before you can comment on or make changes to this bug.