Bug 1287135 - systemd-run --scope is not cleaned up after process end
systemd-run --scope is not cleaned up after process end
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: systemd-maint
Branislav Blaškovič
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 10:16 EST by Branislav Blaškovič
Modified: 2016-08-08 07:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-08 07:19:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Branislav Blaškovič 2015-12-01 10:16:35 EST
Description of problem:
If you run a lot of systemd-run --scope /bin/true processes, you can see some scopes still in "running" state in systemctl -t scope.

Version-Release number of selected component (if applicable):
systemd-219-19.el7_2.2


Steps to Reproduce:
1. The easiest way is to run /CoreOS/systemd/Regression/scope-unit-stress-test

Actual results:
There are still scopes running even after /bin/true quits.

Expected results:
No scopes running.

Additional info:
Comment 1 Branislav Blaškovič 2015-12-01 10:23:03 EST
I split test to 2 phases. One is spawning systemd-run from external script file (which contains for cycle) and another one is spawning it from inline for cycle.

It looks the same but this bug only is present in the "inline" phase, which is really weird. I will try to investigate this more.
Comment 2 Branislav Blaškovič 2016-08-08 07:19:59 EDT
I am not able to reproduce this anymore with the newest systemd.

Closing for now.

Note You need to log in before you can comment on or make changes to this bug.