Bug 1287154 - Libreoffice Calc hangs on sort operation
Libreoffice Calc hangs on sort operation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice (Show other bugs)
6.7
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: David Tardon
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 10:57 EST by Alan Matsuoka
Modified: 2016-05-10 16:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:15:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test spreadsheet (35.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-12-01 10:58 EST, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2015-12-01 10:57:23 EST
Description of problem:
1. open document in Calc
2 highlight all columns
3. select data -> sort -> choose to sort by column B (product) 
4. Calc hangs

Version-Release number of selected component (if applicable):
4.2.8.2-11.el6 

How reproducible:
Always

Steps to Reproduce:

1. open document in Calc
2 highlight all columns
3. select data -> sort -> choose to sort by column B (product) 
4. Calc hangs



Actual results:

Calc runs in an infinite loop

Expected results:

Calc sort should run to completion.

Additional info:

Tried the same operation on  libreoffice 4.3.7.2-5.el7  without a problem.
Comment 1 Alan Matsuoka 2015-12-01 10:58 EST
Created attachment 1100948 [details]
test spreadsheet
Comment 2 David Tardon 2015-12-02 04:24:13 EST
(In reply to Alan Matsuoka from comment #0)
> Additional info:
> 
> Tried the same operation on  libreoffice 4.3.7.2-5.el7  without a problem.

Confirmed it's fixed by the rebase to 4.3.7 we do in rhel-6.8.
Comment 5 Bill Sanford 2016-01-28 15:13:28 EST
Installed RHEL 6.8 and LO

[root@kaitain ~]# yum info libreoffice
Loaded plugins: product-id, refresh-packagekit, search-disabled-repos, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Installed Packages
Name        : libreoffice
Arch        : x86_64
Epoch       : 1
Version     : 4.3.7.2
Release     : 2.el6
Size        : 0.0  
Repo        : installed

This bug is verified fixed.
Comment 7 errata-xmlrpc 2016-05-10 16:15:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0779.html

Note You need to log in before you can comment on or make changes to this bug.