Bug 1287156 - Can't select items from dynamic dropdown
Can't select items from dynamic dropdown
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All Linux
high Severity high
: GA
: 5.5.2
Assigned To: Shveta
Shveta
: ZStream
Depends On: 1283733
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 11:05 EST by Chris Pelland
Modified: 2016-02-10 10:20 EST (History)
14 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283733
Environment:
Last Closed: 2016-02-10 10:20:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dropdown items (51.30 KB, image/png)
2016-01-19 13:13 EST, Shveta
no flags Details

  None (edit)
Comment 2 CFME Bot 2015-12-10 16:46:55 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=755db4dd894ded784905a2e292e6412f3c358c47

commit 755db4dd894ded784905a2e292e6412f3c358c47
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Wed Nov 25 17:41:40 2015 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Wed Dec 9 15:15:27 2015 +0100

    Fix refresh of dynamic dropdown list
    
    Previous selector would incorrectly select two elements
    instead of one, i.e. in the end the updated options would
    be added to incorrect element.
    
    Also, after updating Bootstrap select, we need to 'refresh'
    it to pick up the changes.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287156
    
    Clean cherry pick from commit 0918a151f16b46370ab34c9d8245b86a1690ba4a

 app/assets/javascripts/dialog_field_refresh.js | 3 ++-
 spec/javascripts/dialog_field_refresh_spec.js  | 6 +++---
 2 files changed, 5 insertions(+), 4 deletions(-)
Comment 3 CFME Bot 2015-12-10 16:47:00 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=56dfe71409bf78a8ddc3f17971bf1e151ec6a6a2

commit 56dfe71409bf78a8ddc3f17971bf1e151ec6a6a2
Merge: 95d1dad 755db4d
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Dec 10 16:45:52 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Dec 10 16:45:52 2015 -0500

    Merge branch 'dynamic_dropdown_refresh_fix' into '5.5.z'
    
    Fix refresh of dynamic dropdown list
    
    Previous selector would incorrectly select two elements
    instead of one, i.e. in the end the updated options would
    be added to incorrect element.
    
    Also, after updating Bootstrap select, we need to 'refresh'
    it to pick up the changes.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287156
    
    Clean cherry pick from commit 0918a151f16b46370ab34c9d8245b86a1690ba4a
    
    See merge request !600

 app/assets/javascripts/dialog_field_refresh.js | 3 ++-
 spec/javascripts/dialog_field_refresh_spec.js  | 6 +++---
 2 files changed, 5 insertions(+), 4 deletions(-)
Comment 6 Harpreet Kataria 2016-01-07 18:01:39 EST
Josh,

Can you try to clean/precompile assets after you apply the hotfix, commands I use to clean/precompile assets are:

RAILS_ENV=production rake assets:clean
RAILS_ENV=production rake assets:precompile
and then restart appliance. Let me know if this helps.

~Harpreet
Comment 8 Harpreet Kataria 2016-01-08 16:32:08 EST
Josh, 

Please apply both hot fixes, then rebuild assets & restart appliance.
Let me know if you have questions.

Thanks,
~Harpreet
Comment 10 Shveta 2016-01-19 13:13 EST
Created attachment 1116296 [details]
dropdown items

Able to select items from dynamic dropdown
Verified in 5.5.2.1.20160114044944_395c086
Comment 11 errata-xmlrpc 2016-02-10 10:20:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.