Bug 1287169 - Merge upstream pull request - ceph rgw/civetweb support
Merge upstream pull request - ceph rgw/civetweb support
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Emilien Macchi
Yogev Rabl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 11:26 EST by Keith Schincke
Modified: 2016-04-07 17:15 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.11-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:15:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 252020 None None None Never
OpenStack gerrit 254548 None None None 2016-02-02 04:54 EST

  None (edit)
Description Keith Schincke 2015-12-01 11:26:40 EST
Description of problem:
Upstream pull request (1) has been created to add rgw support using civetweb to the ceph puppet modules. This includes a few parameters to configure the deployment and configuration of the service. 

1: https://github.com/redhat-openstack/openstack-puppet-modules/pull/290

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Jason Guiditta 2016-02-01 13:17:15 EST
I see the upstream patch is abandoned, do we still need this BZ, or has the problem been solved elsewhere?
Comment 3 Emilien Macchi 2016-02-02 04:54:59 EST
I think the patch is now https://review.openstack.org/#/c/254548/

CI is not passing on upstream, we won't backport it downstream until upstream CI is passing and we have it merged.

The upstream patch breaks unit tests & functional tests.
I had a look at the failures, and there is definitely something wrong in the patch. Did you run unit tests? Did you test it on both ubuntu & centos?
Comment 4 Jason Guiditta 2016-02-29 12:47:33 EST
Merged upstream
Comment 7 errata-xmlrpc 2016-04-07 17:15:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.