Bug 1287216 - [RFE] E-mail Scheduled Report target list too broad
[RFE] E-mail Scheduled Report target list too broad
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
unspecified Severity high
: GA
: 5.6.0
Assigned To: Libor Pichler
Jiri Stefanisin
: FutureFeature, ZStream
Depends On:
Blocks: 1329411 1329415 1343973
  Show dependency treegraph
 
Reported: 2015-12-01 14:12 EST by Josh Carter
Modified: 2016-06-29 11:14 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Enhancement
Doc Text:
Feature: When scheduling an e-mailed report, the "To" dropdown list is showing all users in the logged-in customer's role rather than group. Reason: Email addressed exposed that shouldn't be. Result: Restrict the list of e-mails by current user's groups.
Story Points: ---
Clone Of:
: 1329411 1329415 1343973 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:14:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 CFME Bot 2016-01-21 14:39:24 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/0803961a393875685d6c2ed1d9586caf5c522653

commit 0803961a393875685d6c2ed1d9586caf5c522653
Author:     lpichler <lpichler@redhat.com>
AuthorDate: Wed Jan 20 14:23:23 2016 +0100
Commit:     lpichler <lpichler@redhat.com>
CommitDate: Thu Jan 21 17:50:10 2016 +0100

    Restrict the list of e-mails by current user's groups
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287216
    Logged user can belongs to a few groups.
    This list of emails contains only emails from these groups not all
    emails.

 app/controllers/application_controller.rb | 11 ++++++-----
 app/models/user.rb                        |  4 ++++
 2 files changed, 10 insertions(+), 5 deletions(-)
Comment 6 CFME Bot 2016-04-25 09:56:15 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=e77add0386ea17bd15bbc56489db52281c335aad

commit e77add0386ea17bd15bbc56489db52281c335aad
Author:     lpichler <lpichler@redhat.com>
AuthorDate: Wed Jan 20 14:23:23 2016 +0100
Commit:     lpichler <lpichler@redhat.com>
CommitDate: Fri Apr 22 11:34:14 2016 +0200

    Restrict the list of e-mails by current user's groups
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287216
    Logged user can belongs to a few groups.
    This list of emails contains only emails from these groups not all
    emails.
    
    (cherry picked from commit 0803961a393875685d6c2ed1d9586caf5c522653)

 app/controllers/application_controller.rb | 11 ++++++-----
 app/models/user.rb                        |  4 ++++
 2 files changed, 10 insertions(+), 5 deletions(-)
Comment 9 CFME Bot 2016-06-21 11:57:16 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2b6d2536a54d73cdfb58f4f5a9f4531fe158b135

commit 2b6d2536a54d73cdfb58f4f5a9f4531fe158b135
Author:     lpichler <lpichler@redhat.com>
AuthorDate: Wed Jan 20 14:23:23 2016 +0100
Commit:     lpichler <lpichler@redhat.com>
CommitDate: Wed Jun 15 17:26:26 2016 +0200

    Restrict the list of e-mails by current user's groups
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287216
    Logged user can belongs to a few groups.
    This list of emails contains only emails from these groups not all
    emails.

 vmdb/app/controllers/application_controller.rb | 13 +++++++------
 vmdb/app/models/user.rb                        |  5 ++++-
 2 files changed, 11 insertions(+), 7 deletions(-)
Comment 11 errata-xmlrpc 2016-06-29 11:14:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.