Bug 1287219 - [Backport] haproxy endpoing checks create a performance impacting loop for application restarts.
[Backport] haproxy endpoing checks create a performance impacting loop for ap...
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image (Show other bugs)
2.2.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Timothy Williams
Anping Li
:
Depends On:
Blocks: 1273542
  Show dependency treegraph
 
Reported: 2015-12-01 14:28 EST by Eric Rich
Modified: 2016-06-20 12:19 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285084
Environment:
Last Closed: 2016-06-20 12:19:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 6 Anping Li 2016-02-14 06:19:25 EST
After update, the cartridge version are same as before. I think we should assign a new version in manifest.yml.
Comment 7 Anping Li 2016-02-15 00:13:43 EST
The performance impacting disappears once this patch was enabled. For existing applications, the customer need to call oo-admin-upgrade to replace the Haproxy inner applications (if there are other commands, please let me known).

For upgrade, there isn't any issue related to this patch. there are two little issue about nodejs and php packages. 
 1) nodejs010-nodejs-debug-0.7.2-1.el6op.noarch may be replace with non-ose packages '2.2.0-2.el6' from rhscl
 2) there are Dependency error if we upgrade php-common-5.3.3-40 to php-common-5.3.3-46
Comment 8 Timothy Williams 2016-02-16 14:35:47 EST
Bumping the cartridge version is going to cause a minor issue. The compatible-versions list in the cartridge manifest must be maintained with prior versions that don't require a restart when upgraded - otherwise the users will experience unnecessary downtime. Since I can't retroactively add a '0.0.23.2' entry to the compatible versions list of the newer openshift enterprise haproxy cartridge packages, I've bumped the version to 0.0.24.

0.0.24 is in the list of compatible versions for the enterprise rpms and shouldn't cause the unnecessary downtime. Usually a 3-digit cartridge version would denote an upstream cartridge, but I think this should be acceptable in this case. Could you please re-test with the new rpm in the following build:

  https://brewweb.devel.redhat.com/taskinfo?taskID=10503866

Even though its unrelated, could you give us more details on the php-common dependency issue. We expect the nodejs package to be updated and will handle that appropriately in the next release (2.2.9). We have not aware of the php-common dependency issue though. Could you give us the specific dependency issue output from yum that you are seeing? Also, can you describe your yum repository configuration?
Comment 9 Anping Li 2016-02-16 22:03:26 EST
Verified and pass with package in brew. Below is the step to apply this patch.

1. yum update openshift-origin-cartridge-haproxy-1.30.1.2-1.el6op.noarch.rpm
2. service ruby193-mcollective restart
on broker:
3. oo-admin-ctl-cartridge -c import-profile --activate
4. oo-admin-upgrade upgrade-node --version=0.0.24

Note You need to log in before you can comment on or make changes to this bug.