Bug 1287223 - Host API does not return all parameters for locations
Host API does not return all parameters for locations
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.1.5
All Linux
high Severity high (vote)
: Beta
: --
Assigned To: Katello Bug Bin
Stephen Benjamin
http://projects.theforeman.org/issues...
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 14:37 EST by Karl Abbott
Modified: 2017-10-06 06:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:00:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen Capture from Credit Suisse parameter section. (26.18 KB, image/png)
2015-12-01 14:39 EST, Karl Abbott
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1257339 None None None Never
Foreman Issue Tracker 11763 None None None 2015-12-17 08:56 EST

  None (edit)
Comment 1 Karl Abbott 2015-12-01 14:39 EST
Created attachment 1100990 [details]
Screen Capture from Credit Suisse parameter section.
Comment 3 Brad Buckingham 2016-01-04 10:46:22 EST
Created redmine issue http://projects.theforeman.org/issues/12981 from this bug
Comment 4 Bryan Kearney 2016-01-04 12:01:28 EST
Upstream bug component is Provisioning
Comment 5 Bryan Kearney 2016-01-04 16:53:09 EST

*** This bug has been marked as a duplicate of bug 1257339 ***
Comment 6 Bryan Kearney 2016-01-05 16:44:33 EST
Sorry.. too agressive at closing things out. 

Per the comments from https://bugzilla.redhat.com/show_bug.cgi?id=1257339

Whereas the bug you are presenting is that we are not displaying all parameters for *Location*
I believe this is worth opening a new bug (and we'll solve it faster than I respond to bugzillas :) )

Reopening.
Comment 7 Bryan Kearney 2016-02-17 04:02:17 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/12981 has been closed
Comment 9 Stephen Benjamin 2016-03-24 13:37:42 EDT
VERIFIED: "all_parameters" key on the hosts api shows all inherited parameters, including from the Locations and Organizations.


Example:

    "all_parameters": [
        {
            "id": 1,
            "name": "kt_activation_keys",
            "value": "rhel7-client"
        },
        {
            "id": 3,
            "name": "location_param",
            "value": "foo"
        }
    ],
Comment 12 errata-xmlrpc 2016-07-27 05:00:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.