Bug 1287260 - From time to time the ci jobs fail with 'lmonitor socket did not show up: No such file or directory'
From time to time the ci jobs fail with 'lmonitor socket did not show up: No ...
Status: CLOSED DUPLICATE of bug 1271183
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
: Reopened
Depends On: 1271183 1301391
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 15:39 EST by David Caro
Modified: 2016-06-26 19:51 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-11 19:05:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Caro 2015-12-01 15:39:02 EST
Description of problem:
Sometimes the ci jobs fail to run the functional tests when doing the prefix startup, and they fail with:

 
19:15:08 not ok 8 basic.full_run: start everything at once
19:15:08 # (from function `helpers.equals' in file tests/functional/helpers.bash, line 49,
19:15:08 #  in test file tests/functional/basic.bats, line 126)
19:15:08 #   `helpers.equals "$status" '0'' failed
19:15:08 # RUNNING:lagocli start
19:15:08 # WARNING: current session does not belong to lago group.
19:15:08 # 2015-12-01 19:14:13,413 - root - INFO - Creating network lago_functional_tests
19:15:08 # 2015-12-01 19:14:17,934 - root - INFO - Starting VM lago_functional_tests_vm01
19:15:08 # libvirt: QEMU Driver error : monitor socket did not show up: No such file or directory
19:15:08 # 2015-12-01 19:15:04,689 - root - INFO - Destroying network lago_functional_tests
19:15:08 # 2015-12-01 19:15:08,351 - root - ERROR - Error occured, aborting
19:15:08 # Traceback (most recent call last):
19:15:08 #   File "/usr/bin/lagocli", line 528, in main
19:15:08 #     func(args)
19:15:08 #   File "/usr/bin/lagocli", line 85, in wrapper
19:15:08 #     return func(lago.Prefix(os.getcwd()), args)
19:15:08 #   File "/usr/bin/lagocli", line 93, in wrapper
19:15:08 #     return func(prefix, args)
19:15:08 #   File "/usr/bin/lagocli", line 106, in do_start
19:15:08 #     prefix.start()
19:15:08 #   File "/usr/lib/python2.7/site-packages/lago/__init__.py", line 594, in start
19:15:08 #     self.virt_env.start()
19:15:08 #   File "/usr/lib/python2.7/site-packages/lago/virt.py", line 138, in start
19:15:08 #     vm.start()
19:15:08 #   File "/usr/lib/python2.7/site-packages/lago/virt.py", line 756, in start
19:15:08 #     self._env.libvirt_con.createXML(self._libvirt_xml())
19:15:08 #   File "/usr/lib64/python2.7/site-packages/libvirt.py", line 3611, in createXML
19:15:08 #     if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
19:15:08 # libvirtError: monitor socket did not show up: No such file or directory
19:15:08 # 1 == 0

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 David Caro 2016-01-26 04:37:55 EST
This seems to be an issue in libvirt, that is not able to create the per-user socket fast enough (or the client does not wait enough time for it to appear)
Comment 2 David Caro 2016-01-26 04:43:45 EST
Moved to https://github.com/lago-project/lago/issues/32
Comment 3 Fabian Deutsch 2016-03-30 07:37:23 EDT
Reopening this issue and moving it to libvirt.

Is is - now and then - blocking our - oVirt - CI:
Comment 4 Cole Robinson 2016-04-11 19:05:58 EDT
This is likely bug 1271183, which should be fixed as of the latest libvirt-1.2.13.2-3.fc22. Duping to that, but please reopen if you can reproduce with that package

*** This bug has been marked as a duplicate of bug 1271183 ***

Note You need to log in before you can comment on or make changes to this bug.