Bug 1287262 - dnf system upgrade fails due to libxml2 dependency
dnf system upgrade fails due to libxml2 dependency
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
22
Unspecified Linux
urgent Severity urgent
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 15:43 EST by Amedeo Salvati
Modified: 2015-12-04 14:19 EST (History)
7 users (show)

See Also:
Fixed In Version: libxml2-2.9.3-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-04 14:19:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amedeo Salvati 2015-12-01 15:43:30 EST
Description of problem:
Upgrading from fedora 22 to 23 fails due to depsolve problems on libxml2

Version-Release number of selected component (if applicable):
libxml2-python-2.9.3-1.fc22.x86_64

How reproducible:
Always

Steps to Reproduce:
1.# dnf  system-upgrade download --releasever=23
Last metadata expiration check performed 0:06:39 ago on Tue Dec  1 21:32:58 2015.
Error: package libxml2-python-2.9.3-1.fc22.x86_64 requires libxml2 = 2.9.3-1.fc22, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)
2. # rpm -qa | grep libxml2
libxml2-2.9.3-1.fc22.x86_64
libxml2-devel-2.9.3-1.fc22.x86_64
libxml2-python-2.9.3-1.fc22.x86_64

Actual results:
Upgrade fails

Expected results:


Additional info:
Comment 1 Adam Williamson 2015-12-01 17:20:04 EST
This is a straight up packaging error, and it needs fixing urgently as it's breaking a lot of F23 upgrades.

The problem is this. The subpackage got renamed from libxml2-python to python-libxml2 for F23. An Obsoletes was added:

Obsoletes: %{name}-python < 2.9.2-6

and that worked fine...but then the packager broke it by doing a new F22 build:

http://koji.fedoraproject.org/koji/buildinfo?buildID=700502

That's versioned 2.9.3-1.fc22, but still uses the libxml2-python name for the python subpackage, not python-libxml2.

So now we have a libxml2-python-2.9.3-1.fc22 , and python-libxml2-2.9.3-1.fc23 will not obsolete it, because 2.9.3-1 is greater than 2.9.2-6. The version on the obsoletes needs to be bumped.
Comment 3 Fedora Update System 2015-12-02 13:51:30 EST
libxml2-2.9.3-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-48362b03d1
Comment 4 Fedora Update System 2015-12-03 20:35:44 EST
libxml2-2.9.3-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update libxml2'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-48362b03d1
Comment 5 Hjalmar Eysteinsson 2015-12-04 06:21:05 EST
This error still appears while running 'fedora-upgrade'on Fedora 22
Comment 6 Marek Zdunek 2015-12-04 11:45:55 EST
Just downgrade
 libxml2-2.9.2-4.fc22.x86_64.rpm
 libxml2-python-2.9.2-4.fc22.x86_64.rpm
download rpm from koji
http://koji.fedoraproject.org/koji/buildinfo?buildID=683982
Comment 7 Adam Williamson 2015-12-04 11:53:27 EST
The update is still in testing, so unless you have the updates-testing repository enabled as part of your upgrade process, you'll still see the bug, yeah. It'll stop when the upgrade goes stable.
Comment 8 Fedora Update System 2015-12-04 14:19:32 EST
libxml2-2.9.3-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.