Bug 1287271 - Add the package to EPEL7 repos
Add the package to EPEL7 repos
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python-django-debug-toolbar (Show other bugs)
rawhide
All All
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 16:05 EST by fedora.dm0
Modified: 2015-12-02 06:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 06:53:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fedora.dm0 2015-12-01 16:05:39 EST
Description of problem:
The module is available in EPEL for RHEL6 systems, but not on RHEL7.

Version-Release number of selected component (if applicable):
1.3.0-2 (current HEAD)

How reproducible:
Always

Steps to Reproduce:
1. sudo yum install python-django-debug-toolbar # on RHEL7

Actual results:
No package python-django-debug-toolbar available.

Expected results:
The package should be installed.

Additional info:
I built the latest version with mock for epel-7-x86_64, and it needed a small fix.  Change this line:

http://pkgs.fedoraproject.org/cgit/python-django-debug-toolbar.git/tree/python-django-debug-toolbar.spec#n117

To this:

%if 0%{?with_python3}

It looks like this is also why builds in #1087349 are failing.
Comment 1 Matthias Runge 2015-12-02 06:53:04 EST
Oh yes, good catch! that if is wrong in spec. I'd fix that as soon as I can.


I'm a bit hesitant to add this to epel7, in fact, it should be deprecated in epel6, since there is no supported Django version in epel6.

The main reason is, django is a moving target, and it's moving a bit too fast for a long term supported release like RHEL

For example, we currently can not upgrade from django-1.6 in epel7 to the recent long term supported version django-1.8, since we'd break current installations and a few packages in epel7.

Note You need to log in before you can comment on or make changes to this bug.