Bug 1287280 - Volume detach fails because failure to delete initiator [lvm]
Volume detach fails because failure to delete initiator [lvm]
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: ---
: 7.0 (Kilo)
Assigned To: Eric Harney
lkuchlan
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 16:21 EST by Jeremy
Modified: 2017-07-18 10:10 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-cinder-2015.1.2-6.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-26 11:29:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1522053 None None None Never
OpenStack gerrit 252460 None None None Never

  None (edit)
Comment 3 Jeremy 2015-12-01 17:25:57 EST
I ran cinder-rtstool delete-initiator [target_iqn] [initiator_iqn] ,

when the initiator was in all caps it hits exception, which is the problem I see. When I do it manually and enter the initiator iqn in lower case it successfully deletes the initiator iqn.
Comment 8 lkuchlan 2016-04-13 10:03:08 EDT
Tested using:
python-cinderclient-1.2.1-1.el7ost.noarch
python-cinder-2015.1.3-5.el7ost.noarch
openstack-cinder-2015.1.3-5.el7ost.noarch

Verification flow:

1. Creating an instance

[stack@instack ~]$ nova boot --image 25e14562-0c56-4b7d-be97-f481f28da440 --flavor 1 --nic net-id=9f2c1691-7d46-4899-8f34-ec648eb9ec83 vm1
+--------------------------------------+-----------------------------------------------+
| Property                             | Value                                         |
+--------------------------------------+-----------------------------------------------+
| OS-DCF:diskConfig                    | MANUAL                                        |
| OS-EXT-AZ:availability_zone          |                                               |
| OS-EXT-SRV-ATTR:host                 | -                                             |
| OS-EXT-SRV-ATTR:hypervisor_hostname  | -                                             |
| OS-EXT-SRV-ATTR:instance_name        | instance-00000003                             |
| OS-EXT-STS:power_state               | 0                                             |
| OS-EXT-STS:task_state                | scheduling                                    |
| OS-EXT-STS:vm_state                  | building                                      |
| OS-SRV-USG:launched_at               | -                                             |
| OS-SRV-USG:terminated_at             | -                                             |
| accessIPv4                           |                                               |
| accessIPv6                           |                                               |
| adminPass                            | 5TJk8C7znwKx                                  |
| config_drive                         |                                               |
| created                              | 2016-04-13T13:33:18Z                          |
| flavor                               | m1.tiny (1)                                   |
| hostId                               |                                               |
| id                                   | 9c0b16df-99db-4384-8ff5-92dbad51c7d4          |
| image                                | cirros (25e14562-0c56-4b7d-be97-f481f28da440) |
| key_name                             | -                                             |
| metadata                             | {}                                            |
| name                                 | vm1                                           |
| os-extended-volumes:volumes_attached | []                                            |
| progress                             | 0                                             |
| security_groups                      | default                                       |
| status                               | BUILD                                         |
| tenant_id                            | e9dce6466d2b46f48eba013835d24237              |
| updated                              | 2016-04-13T13:33:19Z                          |
| user_id                              | ee55d61964f84a1f8e867db5e7124d8e              |
+--------------------------------------+-----------------------------------------------+

[stack@instack ~]$ nova list
+--------------------------------------+------+--------+------------+-------------+--------------------+
| ID                                   | Name | Status | Task State | Power State | Networks           |
+--------------------------------------+------+--------+------------+-------------+--------------------+
| 9c0b16df-99db-4384-8ff5-92dbad51c7d4 | vm1  | ACTIVE | -          | Running     | net1=192.168.100.5 |
+--------------------------------------+------+--------+------------+-------------+--------------------+

2. Creating a volume

[stack@instack ~]$ cinder create 1
+---------------------+--------------------------------------+
|       Property      |                Value                 |
+---------------------+--------------------------------------+
|     attachments     |                  []                  |
|  availability_zone  |                 nova                 |
|       bootable      |                false                 |
|      created_at     |      2016-04-13T13:48:34.288843      |
| display_description |                 None                 |
|     display_name    |                 None                 |
|      encrypted      |                False                 |
|          id         | 1da3c05a-577b-4b03-8dd2-b4449cf90dd0 |
|       metadata      |                  {}                  |
|     multiattach     |                false                 |
|         size        |                  1                   |
|     snapshot_id     |                 None                 |
|     source_volid    |                 None                 |
|        status       |               creating               |
|     volume_type     |                 None                 |
+---------------------+--------------------------------------+

[stack@instack ~]$ cinder list
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
|                  ID                  |   Status  | Display Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
| 1da3c05a-577b-4b03-8dd2-b4449cf90dd0 | available |      -       |  1   |      -      |  false   |             |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+

3. Attaching volume to instance 

[stack@instack ~]$ nova volume-attach 9c0b16df-99db-4384-8ff5-92dbad51c7d4 1da3c05a-577b-4b03-8dd2-b4449cf90dd0
+----------+--------------------------------------+
| Property | Value                                |
+----------+--------------------------------------+
| device   | /dev/vdb                             |
| id       | 1da3c05a-577b-4b03-8dd2-b4449cf90dd0 |
| serverId | 9c0b16df-99db-4384-8ff5-92dbad51c7d4 |
| volumeId | 1da3c05a-577b-4b03-8dd2-b4449cf90dd0 |
+----------+--------------------------------------+

[stack@instack ~]$ cinder list
+--------------------------------------+----------+--------------+------+-------------+----------+--------------------------------------+
|                  ID                  |  Status  | Display Name | Size | Volume Type | Bootable |             Attached to              |
+--------------------------------------+----------+--------------+------+-------------+----------+--------------------------------------+
| 1da3c05a-577b-4b03-8dd2-b4449cf90dd0 |  in-use  |      -       |  1   |      -      |  false   | 9c0b16df-99db-4384-8ff5-92dbad51c7d4 |
+--------------------------------------+----------+--------------+------+-------------+----------+--------------------------------------+

4. Detaching the volume

[stack@instack ~]$ nova volume-detach 9c0b16df-99db-4384-8ff5-92dbad51c7d4 1da3c05a-577b-4b03-8dd2-b4449cf90dd0

[stack@instack ~]$ cinder list
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
|                  ID                  |   Status  | Display Name | Size | Volume Type | Bootable | Attached to |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
| 1da3c05a-577b-4b03-8dd2-b4449cf90dd0 | available |      -       |  1   |      -      |  false   |             |
+--------------------------------------+-----------+--------------+------+-------------+----------+-------------+
Comment 10 errata-xmlrpc 2016-04-26 11:29:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0688.html

Note You need to log in before you can comment on or make changes to this bug.