Bug 1287299 - Host does not comply with the cluster emulated machines
Host does not comply with the cluster emulated machines
Status: CLOSED DUPLICATE of bug 1287126
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: nobody nobody
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 17:35 EST by Marina
Modified: 2016-01-11 11:30 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-03 00:56:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marina 2015-12-01 17:35:47 EST
Description of problem:
Cannot add RHEL 7.2 host to RHEV-M 3.6 beta1.
Host becomes non operational.
The error in the engine.log:
~~~
Message: Host rhevh-19 does not comply with the cluster Default emulated machines. The current cluster compatibility level supports [pc-i440fx-rhel7.2.0, pseries-rhel7.2.0] and the host emulated machines are pc-i440fx-rhel7.1.0,rhel6.3.0,q35,rhel6.1.0,rhel6.6.0,rhel6.2.0,pc,pc-q35-rhel7.1.0,pc-q35-rhel7.0.0,rhel6.4.0,rhel6.0.0,rhel6.5.0,pc-i440fx-rhel7.0.0.
~~~


Version-Release number of selected component (if applicable):
rhevm-3.6.0.3-0.1.el6.noarch

host:
vdsm-4.17.10.1-0.el7ev.noarch
Red Hat Enterprise Linux Server release 7.2 (Maipo)

How reproducible:
100% ?

Steps to Reproduce:
1. Run hosted-engine -- deploy and choose to install rhevm from pxe.
2. Install rhevm os from pxe and then setup the engine. (engine-setup succeeded)
3. 

Actual results:
Cannot continue with hosted-engine installation since the host is non-operational.

Expected results:
The setup should detected the correct settings from the host and create the cluster with appropriate settings.



Additional info:
Workaround: modify ClusterEmulatedMachines config value.

Original, default value:
~~~
# engine-config -g ClusterEmulatedMachines
ClusterEmulatedMachines: pc-i440fx-rhel7.2.0,pseries-rhel7.2.0 version: 3.6
ClusterEmulatedMachines: rhel6.5.0,pseries version: 3.5
ClusterEmulatedMachines: rhel6.5.0,pseries version: 3.4
ClusterEmulatedMachines: rhel6.5.0 version: 3.3
ClusterEmulatedMachines: rhel6.4.0 version: 3.2
ClusterEmulatedMachines: rhel6.3.0 version: 3.1
ClusterEmulatedMachines: rhel6.2.0 version: 3.0
~~~
New value:
~~~
# engine-config -s ClusterEmulatedMachines=pc-i440fx-rhel7.2.0,pseries-rhel7.2.0,pc-i440fx-rhel7.1.0
~~~


Also: I do not know where those values are coming from, but this host was installed with RHEL7.1 and then upgraded to 7.2.
Comment 1 Bimal Chollera 2015-12-01 18:50:40 EST
qemu-kvm-rhev pkg.

~~~
vdsm-4.17.10.1-0.el7ev.noarch

qemu-kvm-common-rhev-2.1.2-23.el7_1.10.x86_64
qemu-img-rhev-2.1.2-23.el7_1.10.x86_64
qemu-kvm-rhev-2.1.2-23.el7_1.10.x86_64
qemu-kvm-tools-rhev-2.1.2-23.el7_1.10.x86_64

# /usr/libexec/qemu-kvm -M help
Supported machines are:
pc                   RHEL 7.1.0 PC (i440FX + PIIX, 1996) (alias of pc-i440fx-rhel7.1.0)
pc-i440fx-rhel7.1.0  RHEL 7.1.0 PC (i440FX + PIIX, 1996) (default)
pc-i440fx-rhel7.0.0  RHEL 7.0.0 PC (i440FX + PIIX, 1996)
rhel6.6.0            RHEL 6.6.0 PC
rhel6.5.0            RHEL 6.5.0 PC
rhel6.4.0            RHEL 6.4.0 PC
rhel6.3.0            RHEL 6.3.0 PC
rhel6.2.0            RHEL 6.2.0 PC
rhel6.1.0            RHEL 6.1.0 PC
rhel6.0.0            RHEL 6.0.0 PC
q35                  RHEL-7.1.0 PC (Q35 + ICH9, 2009) (alias of pc-q35-rhel7.1.0)
pc-q35-rhel7.1.0     RHEL-7.1.0 PC (Q35 + ICH9, 2009)
pc-q35-rhel7.0.0     RHEL-7.0.0 PC (Q35 + ICH9, 2009)
none                 empty machine
~~~


~~~
vdsm-4.17.10.1-0.el7ev.noarch

qemu-kvm-common-rhev-2.3.0-31.el7_2.3.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.3.x86_64
qemu-kvm-tools-rhev-2.3.0-31.el7_2.3.x86_64

# /usr/libexec/qemu-kvm -M help
Supported machines are:
pc                   RHEL 7.2.0 PC (i440FX + PIIX, 1996) (alias of pc-i440fx-rhel7.2.0)
pc-i440fx-rhel7.2.0  RHEL 7.2.0 PC (i440FX + PIIX, 1996) (default)
pc-i440fx-rhel7.1.0  RHEL 7.1.0 PC (i440FX + PIIX, 1996)
pc-i440fx-rhel7.0.0  RHEL 7.0.0 PC (i440FX + PIIX, 1996)
rhel6.6.0            RHEL 6.6.0 PC
rhel6.5.0            RHEL 6.5.0 PC
rhel6.4.0            RHEL 6.4.0 PC
rhel6.3.0            RHEL 6.3.0 PC
rhel6.2.0            RHEL 6.2.0 PC
rhel6.1.0            RHEL 6.1.0 PC
rhel6.0.0            RHEL 6.0.0 PC
q35                  RHEL-7.2.0 PC (Q35 + ICH9, 2009) (alias of pc-q35-rhel7.2.0)
pc-q35-rhel7.2.0     RHEL-7.2.0 PC (Q35 + ICH9, 2009)
pc-q35-rhel7.1.0     RHEL-7.1.0 PC (Q35 + ICH9, 2009)
pc-q35-rhel7.0.0     RHEL-7.0.0 PC (Q35 + ICH9, 2009)
none                 empty machine
~~~
Comment 2 Marina 2015-12-01 20:10:58 EST
Relevant upstream bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1229396
Comment 3 Oved Ourfali 2015-12-03 00:56:51 EST

*** This bug has been marked as a duplicate of bug 1287126 ***

Note You need to log in before you can comment on or make changes to this bug.