Bug 128731 - system lockup when using quota on ext2/ext3/reiserfs
system lockup when using quota on ext2/ext3/reiserfs
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-07-28 15:50 EDT by harald kapper
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.7-1.494.2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-03 20:25:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description harald kapper 2004-07-28 15:50:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)

Description of problem:
problem also present in kernel-2.6.6-1.435.2.3

simply enable quota on a big partition (eg. 100 GB) using ext3fs -
after a while of access to this mounted partition eg under /home -
access to this partition is locked down - disk-access-tries end up in
timeouts / locks.

tried on completely differnet hardware, problem always arises (using
p4 or athlon cpu, using msi-mainboard and sis-mainboard, using
different harddisks, differnt ide-controller,..)

problem is also arising when running ext2fs, using no quotas on the
partition -> no problem at all.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. enable quotas like eg.
/dev/md3                /home                   ext3   
defaults,usrquota,grpquota      0 0
2. remount this partition, do a quotacheck - everything is setup.
3. now give users access and let them do filetransfers
4. after a while (sometimes hours) the shell locks up when trying to
access the partition (eg /home via ls /home)
5. only reboot "solves" 

Actual Results:  system unusable after a while

Expected Results:  should work with quotas without any trouble

Additional info:

no problem using the same config on fedora-core-1 (2.4.22-1.2197.nptl)
seen lots of similar problems in the ext3-mailinglist, but unsure
whether all those discussions I read still apply.
Comment 1 harald kapper 2004-07-29 10:20:29 EDT
tried the very same config with the latests V2.6.7 kernel compiled
from kernel.org - filesystem blocks itself out of the way too.

I guess this is a quota+ext3 bug somehow here...
Comment 2 Ben Thomas 2004-07-29 15:45:22 EDT
I can confirm this issue using 2.6.6-1.435.2.3. After building a new
2.6.7 kernel, this issue is resolved on my systems.
Comment 3 harald kapper 2004-07-29 18:01:14 EDT
Ben - would you share your .config for your 2.6.7 kernel?

btw. I also tested quota-support using reiserfs, but it does lock up
using reiserfs instead of ext3 too;
then I got curious and finally in using xfs (thx sgi!) we are now able
to use 2.6.7-vanilla- and the 2.6.6-1.435.2.3-fedora-kernel at least
with one filesystem that supports quotas without locking up the system.
Comment 4 Ben Thomas 2004-07-29 18:58:58 EDT
I patched the kernel with Andrew Morton's patchset:


I then used the config provided with Fedora's 2.6.6-1.435.2.3 kernel
by running "make oldconfig" on it.
Comment 5 Marius Andreiana 2004-07-31 07:04:02 EDT
Confirming this. Also found other posts on the net:

Comment 6 harald kapper 2004-08-03 20:25:27 EDT
current kernel-release version 2.6.7-1.494.2.2 solves this problem for me.
Comment 7 Chad 2004-08-31 19:09:37 EDT
I have 2.6.8-1.521smp #1 SMP Mon Aug 16 09:25:06 EDT 2004 i686 i686 
i386 GNU/Linux

Is there a fix for this yet? My exact problem is not a lockup but:
in cPanel's WHM all "quota" shows "0" after running /scripts/fixquotas

Here is what it says when I run /scripts/fixquotas

No filesystems with quota detected.
Resetting quota for zaxcorp to 2000 Meg....Done

more details if it helps:

Note: call resetquota with --useplanquotas to reset all quotas to 
plan defaults
edquota: Quota file not found or has wrong format.
edquota: Quota file not found or has wrong format.
No filesystems with quota detected.
Resetting quota for admin to 500 Meg....Done
edquota: Quota file not found or has wrong format.
edquota: Quota file not found or has wrong format.
No filesystems with quota detected.

root@server [~]# /sbin/quotaoff -a
quotaoff: Cannot find quota file on / [/dev/hda2] to turn quotas 
quotaoff: Cannot find quota file on /extra [/dev/hdb1] to turn quotas 

to me at chad_abizeid@msn.com Thank you.
Comment 8 Chad 2004-08-31 19:13:25 EDT
Add to cc list.
Comment 9 harald kapper 2004-08-31 21:35:04 EDT
please - read the docs of cPanel or ask your support-stuff, you're
reporting your problem - not appropriate to this bug, nor does it show
you at least tried to read the docs.

read the mini-howto on quotas or the quota-howto and then ask for
support on the appropriate mailinglists, do not try to open a bug
again if it has been solved, especially if it is totally unrelated to
your problem - at least try to read the error-messages you get and
take appropriate action.

sorry, no offense meant, but I guess you just wasted some peoples time.

Note You need to log in before you can comment on or make changes to this bug.