Bug 1287317 - sddm-theme-hawaii: White screen making it unusable
sddm-theme-hawaii: White screen making it unusable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hawaii-shell (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Pier Luigi Fiorini
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-01 18:31 EST by Sylvia Sánchez
Modified: 2016-02-07 03:20 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-07 03:20:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sylvia Sánchez 2015-12-01 18:31:19 EST
Description of problem:
When SDDM should show up, it doesn't; there's only a white screen without cursor, buttons or anything else. I can only login my user typing  <Ctrl+Alt+F2>

Version-Release number of selected component (if applicable):


How reproducible: 
Using SDDM.


Steps to Reproduce:
1. Start computer.
2. Wait for SDDM to start.


Actual results:
White screen.


Expected results:
A screen with a theme or another that allows me to login.

Additional info:
Using Hawaii theme, installing via DNF.
Comment 1 Rex Dieter 2015-12-01 19:24:58 EST
Probably a theming issue, triaging to hawaii

A workaround in the meantime would be to use some other (non-problematic) theme
Comment 2 Pier Luigi Fiorini 2015-12-02 04:14:31 EST
A temporary workaround is to install the hawaii-shell package.
Until I split it up and move the components into a subpackage.
Comment 3 Sylvia Sánchez 2015-12-02 04:51:41 EST
I'll try both workaround (other theme & hawaii shell) and add the output.
Comment 4 Fedora Update System 2015-12-03 13:32:46 EST
hawaii-shell-0.5.92-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ea5d2e2e79
Comment 5 Fedora Update System 2015-12-04 11:51:22 EST
hawaii-shell-0.5.92-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update hawaii-shell'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ea5d2e2e79
Comment 6 Brian Kaye 2015-12-08 17:04:18 EST
I am experiencing the "white screen" problem with a bare installation of the Fedora 23 KDE spin (which I assume uses plasma shell). I was able to logon on another virtual terminal. I applied all available updates and installed sddm-themes. The problem persists whether using the default sddm theme or any of the alternatives by editing /etc/sddm.conf. 

I installed kdm and switched to it (systemctl stop sddm;systemctl disable sddm; systemctl enable kdm; systemct start kdm), rebooted and was able to logon and do useful work. 

I tested sddm-greeter (sddm-greeter --test --theme /usr/share/sddm/themes/maui). I tried all the themes successfully in a terminal after logging on using kdm as the display manager. 

I have a IBM ThinkPad T42P laptop running Fedora 22 which I successfully switched to sddm. Both are running sddm-0.13.0-4.

When comparing the processes on the two machines the failing one (fedora 23) has an extra process with the USER sddm. Its running "dbus-launch -autolaunch  ......  --binary-syntax --close-stderr". The "......" is a long string of hex. 
The sddm-greeter process is missing on the god machine because I have logged on. The rest of the processes commands are the same except for the sockets.

On the failing machine (Fedora 23 KDE spin) the last message in the journal (journalctl -b -u sddm) is  :

sddm-helper[1473] pam_unix(sddm-greeter:session): session opened for user sddm by (uid=0).
 
I can use kdm so Fedora 23 the machine is usable, but it does not restore the previous session after a restart. That is a different bug. Not sure if sddm will fix that but first I need to get past the sddm logon.

Looking for things to try to find out where the problem is.
Comment 7 Brian Kaye 2015-12-08 17:05:42 EST
I am on 32bit I686 hardware not 64bit like the original filer of this bug.
Comment 8 Brian Kaye 2015-12-08 17:51:37 EST
Just tinkering with the white screen, clicked on  a few places on the screen to see if anything happened. When I clicked on the upper right the screen went black and the machine powered off. Stranger and stranger. Repeated with more rigorous clicks and only the upper right corner causes the power off. Very repeatable.


There is a message  from sddm-greeter "QOpenGLShader: could not create shader" repeated 6 time in the log well before I clicked. 

After a reboot and once again getting the white screen I  examined the log (journalctl -b -1).The  first message was 
systemd-logind[646]: System is powering down. 

A few messages later  was 
sddm[875]: Error from greeter session: "Process Crashed"
sddm[875]: Auth:sddm-helper crashed (exit code 15)
sddm[875]: Error from greeter session: "Process crashed"
sddm[875]: Auth: sddm-helper exited with 15
....
sddm[875]: Signal received: SIGTERM
Comment 9 Fedora Update System 2015-12-19 13:28:24 EST
hawaii-shell-0.5.92-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Pier Luigi Fiorini 2016-01-11 06:30:38 EST
@Brian Kaye: seems a completely different issue.
Comment 11 Pier Luigi Fiorini 2016-01-11 06:32:19 EST
@Sylvia: did you try updating to see if it's fixed?
Comment 12 Sylvia Sánchez 2016-01-13 08:10:02 EST
@Pier:  I can't check if it's fixed because  1) System Settings hangs when I click on the SDDM section to set it, using Plasma. If I'm using Cinnamon it doesn't hangs but... 2) I can't pick an image as background for SDDM, it only shows folder but no pictures (in folders full of them).
So I cannot say if it's fixed or not.
Comment 13 Pier Luigi Fiorini 2016-02-07 03:20:27 EST
Fixed with latest version.

Note You need to log in before you can comment on or make changes to this bug.