Bug 128736 - Server crash (Signal 11) when attempting to use triple-head setup
Server crash (Signal 11) when attempting to use triple-head setup
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-28 16:14 EDT by Jay Fenlason
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-10 18:16:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config that causes failure. (5.71 KB, text/plain)
2004-07-28 16:20 EDT, Jay Fenlason
no flags Details
Crashed server log (79.62 KB, text/plain)
2004-07-28 16:22 EDT, Jay Fenlason
no flags Details

  None (edit)
Description Jay Fenlason 2004-07-28 16:14:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:


Version-Release number of selected component (if applicable):
XFree86-4.3.0-67.EL

How reproducible:
Always

Steps to Reproduce:
1.Install the attached /etc/X11/XF86Config on
fenlason-desk.boston.redhat.com
2.run xinit
3.
    

Actual Results:  All monitors go black.  X does not start.  System
must be rebooted remotely.

Expected Results:  X should start up.

Additional info:
Comment 1 Jay Fenlason 2004-07-28 16:20:42 EDT
Created attachment 102268 [details]
XF86Config that causes failure.
Comment 2 Jay Fenlason 2004-07-28 16:22:13 EDT
Created attachment 102269 [details]
Crashed server log
Comment 3 Mike A. Harris 2005-03-07 12:08:39 EST
You MUST have "Screen n" keywords in every single device section in
multihead configurations.  Your X server is misconfigured.

There may or may not be additional problems once the X server is
configured properly.  Please correct this and provide a status
update.

Note: our config tools do not properly configure xinerama or other
multihead.  You must configure it manually.
Comment 6 Mike A. Harris 2005-05-10 18:16:41 EDT
The problem reported here is due to X server config file misconfiguration.

While it is true that the X server should not crash even if it is
misconfigured, such a crash is a corner case which is not something that
would work even if the server were fixed to not crash under this
misconfiguration.  As such, the server crash is a low impact bug that
doesn't affect normal supported X server usage.

Please refer to the X server documentation for assistance in configuring
triple head setup, as our tools do not support configuring such setups
currently.

Closing bug "NOTABUG".


Note You need to log in before you can comment on or make changes to this bug.