Bug 1287444 - nova resize fails due to ssh accross compute nodes not setup
nova resize fails due to ssh accross compute nodes not setup
Status: CLOSED DUPLICATE of bug 1404294
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Angus Thomas
Omri Hochman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 01:16 EST by Graeme Gillies
Modified: 2017-09-07 15:03 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-21 08:50:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graeme Gillies 2015-12-02 01:16:59 EST
Director 7.1, RHEL-OSP 7.0.2

When doing a nova resize, it fails with the following error

2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher     return function(self, context, *args, **kwargs) 
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib/python2.7/site-packages/nova/comput
e/manager.py", line 294, in decorated_function                                                                       
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher     migration.instance_uuid, exc_info=True)         
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib/python2.7/site-packages/oslo_utils/
excutils.py", line 85, in __exit__                                                                                   
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher     six.reraise(self.type_, self.value, self.tb)    
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib/python2.7/site-packages/nova/comput
e/manager.py", line 277, in decorated_function                                                                       
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher     return function(self, context, *args, **kwargs) 
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib/python2.7/site-packages/nova/comput
e/manager.py", line 363, in decorated_function                                                                       
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher     kwargs['instance'], e, sys.exc_info())          
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib/python2.7/site-packages/oslo_utils/
excutils.py", line 85, in __exit__                                                                                   
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher     six.reraise(self.type_, self.value, self.tb)    
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib/python2.7/site-packages/nova/comput
e/manager.py", line 351, in decorated_function                                                                       
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher     return function(self, context, *args, **kwargs) 
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib/python2.7/site-packages/nova/comput
e/manager.py", line 4076, in resize_instance                                                                         
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher     self.instance_events.clear_events_for_instance(i
nstance)                                                                                                             
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib64/python2.7/contextlib.py", line 35
, in __exit__                                                                                                        
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher     self.gen.throw(type, value, traceback)          
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher   File "/usr/lib/python2.7/site-packages/nova/comput
e/manager.py", line 6455, in _error_out_instance_on_exception                                                        
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher     raise error.inner_exception                     
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher ResizeError: Resize error: not able to execute ssh c
ommand: Unexpected error while running command.                                                                      
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher Command: ssh 10.9.38.70 mkdir -p /var/lib/nova/insta
nces/ee73d3e2-fcff-4e18-bd86-7e2e699e15bb                                                                            
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher Exit code: 255                                      
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher Stdout: u''                                         
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher Stderr: u'Host key verification failed.\r\n'        
2015-12-02 01:01:21.422 4409 TRACE oslo_messaging.rpc.dispatcher                                                     

Looking in /var/lib/nova/.ssh, it seems that no ssh keys are setup for the nova user, and also there is no .ssh/config file with the following contents

Host *
StrictHostKeyChecking no

Both of these will be needed for resize to work

Regards,

Graeme
Comment 2 Jeremy 2016-02-29 09:09:23 EST
Hello,

Is there any additional info we need for this bug?
Comment 4 Mike Burns 2016-04-07 17:00:12 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 7 Red Hat Bugzilla Rules Engine 2017-02-06 18:35:49 EST
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.
Comment 8 Stephen Gordon 2017-04-21 08:50:33 EDT
This would fall under the work being planned under https://bugzilla.redhat.com/show_bug.cgi?id=1404294 for cold migration scenarios.

*** This bug has been marked as a duplicate of bug 1404294 ***
Comment 9 awaugama 2017-09-07 15:03:52 EDT
Dup -- QE will decide about automating the original

Note You need to log in before you can comment on or make changes to this bug.