Bug 1287471 - RFE : non-HTTP routers
Summary: RFE : non-HTTP routers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Ben Bennett
QA Contact: zhaozhanqi
URL:
Whiteboard:
: 1292243 1303232 (view as bug list)
Depends On:
Blocks: 1267746
TreeView+ depends on / blocked
 
Reported: 2015-12-02 07:53 UTC by Miheer Salunke
Modified: 2019-11-14 07:11 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:31:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC
Red Hat Knowledge Base (Solution) 2159611 None None None 2016-04-26 14:10:22 UTC

Description Miheer Salunke 2015-12-02 07:53:14 UTC
1. Proposed title of this feature request 
non-HTTP routers 
  
3. What is the nature and description of the request?  
The OSE3 model provides services for internal linking and routes for external linking. At the moment, only HTTP is supported for routes. This prevents us from exposing things like a database or a remote EJB or other binary connection.
  
4. Why does the customer need this? (List the business requirements here)  
In our multi-tenant setup, we need to decide which functionality to expose to the world/other tenants. We aim to standardize on HTTP, but this is not always possible (especially when migrating legacy systems). Allowing loadbalanced routes to these binary ports adds a value.
  
5. How would the customer like to achieve this? (List the functional requirements here)
* the HAproxy used for the routers at this moment is capable of handling TCP, so the configuration generated for it should cope with non-HTTP traffic
  
6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
* create a route for a remote EJB
  
7. Is there already an existing RFE upstream or in Red Hat Bugzilla?

What information can you provide around timeframes and urgency?

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
Openshift 3.2
    
10. List any affected packages or components.  
Openshift 3.x
  
11. Would the customer be able to assist in testing this functionality if implemented? 
Yes.

Comment 3 Clayton Coleman 2016-02-07 20:45:56 UTC
Our recommendation is to use Service NodePorts with the product today for this function.  Our documentation should describe how to make service node ports HA by leveraging the same mechanisms the routers use to be HA.

Comment 4 Dan McPherson 2016-02-22 16:09:16 UTC
*** Bug 1303232 has been marked as a duplicate of this bug. ***

Comment 5 Dan McPherson 2016-02-22 16:09:19 UTC
*** Bug 1292243 has been marked as a duplicate of this bug. ***

Comment 8 zhang.wanmin 2016-08-24 01:39:26 UTC
Hi Eric Rich,

I'am glade to see this feature is available in the ose ver3.3.

Thanks!

Comment 12 Meng Bo 2016-09-22 10:11:37 UTC
The feature has been implemented by PR https://github.com/openshift/origin/pull/9454
And the related document will be provided in this PR https://github.com/openshift/openshift-docs/pull/2779/files

Move the bug to verified.

Comment 14 errata-xmlrpc 2016-09-27 09:31:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.