Bug 12875 - no error message for bad user home directory
no error message for bad user home directory
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-23 15:22 EDT by redhat
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhat 2000-06-23 15:22:15 EDT
When adding a new user account in linuxconf, if you type
in a bad home directory where the directory other than the base
directory doesn't exist, the error shows up during the 
password creation, without any clue to what happened.

Example:

I entered in for a user account:

Login name: oracle
Full name: Oracle Database Admin
group: dba
Home directory(opt): /oracle/oracle

But the /oracle directory didn't exist. Since it
was supposed to be /oraclesrv/oracle.  Notice that
the mistake was at a higher directory level and not 
at the leaf level.

Instead of giving me an error message that tells me
something is wrong with the home directory, it gave
me the following message:

smbpasswd: User "oracle" was not found in the system password file.

And since I didn't realize that I was entering the wrong
home directory, this threw me for a loop.

This looks like it does something with samba by the "smbpasswd"
message, and I don't know what would have happened if
I didn't have samba running.

It would be nice to have a proper error message, but I would
not go so far to create the full directory path, since a typo
can cause a pain in the butt if you don't realize that the
path was wrong and everthing went smoothly.
Comment 1 Brent Fox 2002-06-05 12:12:08 EDT
Closing because we don't ship linuxconf anymore
Comment 2 Red Hat Bugzilla 2006-02-21 13:47:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.