Bug 1287515 - [cinder][rbd] snapshot deletion fails when the snapshot has a volume as a child
[cinder][rbd] snapshot deletion fails when the snapshot has a volume as a child
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
unspecified
x86_64 Linux
medium Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Jon Bernard
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 04:22 EST by Yogev Rabl
Modified: 2016-04-26 11:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 17:28:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1463682 None None None Never

  None (edit)
Description Yogev Rabl 2015-12-02 04:22:18 EST
Description of problem:
The deletion of a snapshot failed with the error in cinder's volume.log 
2015-12-02 11:10:49.546 21948 ERROR cinder.volume.manager [req- ... - - -] Delete snapshot failed, due to snapshot busy. 
Earlier, a volume was created from the snapshot, while the volume is active (available or attached to an instance) the snapshot cannot be deleted and there's no message to the client notifying - the deletion failed. 

Version-Release number of selected component (if applicable):
openstack-cinder-7.0.0-2.el7ost.noarch
python-cinderclient-1.4.0-1.el7ost.noarch
python-cinder-7.0.0-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a volume
# cinder create --display-name base 1 
2. Create a snapshot from the volume
# cinder snapshot-create --name snap <base uuid>
3. Create a volume from the snapshot
# cinder create --snapshot-id <snap uuid> --display-name from-snap 1 
4. Attempt to delete the snapshot
# cinder snapshot-delete <snap uuid>

Actual results:
The snapshot is available and there's no message from the client

Expected results:
Either the snapshot will be deleted or the Cinder's client will provide a message notifying - the action failed.

Additional info:
Comment 4 Sergey Gotliv 2015-12-06 11:13:13 EST
Jon,

Please, take a look.
Comment 6 Jon Bernard 2015-12-07 10:39:58 EST
Yeah... This is not "fixed" in my opinion, we can do much better in reporting the reason.  The driver is correct in rejecting the delete request from the user, but the user should receive better indication.  I'm not sure what this looks like from Horizon and thus what the priority of this cli issue is.
Comment 7 Jon Bernard 2016-01-06 17:28:19 EST
Given that cinder is functionally doing the correct thing and only the admin using the command line tool will be a bit confused, and a user would not ever see this, I think we should let it go.  If you disagree please reopen.

Note You need to log in before you can comment on or make changes to this bug.