Bug 1287540 - [Admin Portal] List of problematic clusters missing in operation failure dialog (edit DC - bump up compat level) [NEEDINFO]
[Admin Portal] List of problematic clusters missing in operation failure dial...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.1
Unspecified Unspecified
low Severity low (vote)
: ovirt-4.1.0-alpha
: 4.1.0.2
Assigned To: Phillip Bailey
Jiri Belka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 05:13 EST by Jiri Belka
Modified: 2017-02-01 09:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: A lack of clear delineation between the error message text and list of problematic clusters made it difficult to know whether the list of clusters was being shown properly. Consequence: Users could potentially be confused by the error message, making it difficult for them to correct the underlying problem. Fix: To clearly define the error message text from the problematic cluster list, a colon was added after the message text. Result: The end of the message text and beginning of the problematic clusters list should be clear to users, avoiding the potential of confusion.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-01 09:55:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sbonazzo: needinfo? (phbailey)
rule-engine: ovirt‑4.1+
rule-engine: planning_ack+
dfediuck: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)
screenshot (137.14 KB, image/png)
2015-12-02 05:13 EST, Jiri Belka
no flags Details
New version of error message (15.18 KB, image/png)
2016-08-08 16:50 EDT, Phillip Bailey
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 62091 master MERGED webadmin: Edit error message in DC operation failure dialog 2016-08-09 03:16 EDT
oVirt gerrit 64259 ovirt-engine-4.0 MERGED webadmin: Edit error message in DC operation failure dialog 2016-09-29 04:57 EDT

  None (edit)
Description Jiri Belka 2015-12-02 05:13:01 EST
Created attachment 1101393 [details]
screenshot

Description of problem:
List of problematic clusters missing in operation failure dialog (edit DC - bump up compat level).

When one tries to bump up compat level of a DC and the DC has at least one cluster with lower cluster level than desired compat level of the DC, the operation fails and there's an error dialog which states:

~~~
Operation Canceled
Error while executing action: Cannot update Data Center compatibility version to a value that is greater than its Cluster's version. The following clusters should be upgraded new.
~~~

But as you can see there's now list of "following clusters" in the dialog (see screenshot). I would also say that "Cluster's" should be lowercase as this is not refering to name or special object (maintab...).

Version-Release number of selected component (if applicable):
rhevm-3.6.1-0.2.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. have 3.6.x engine
2. (you need to decrease to 3.5 if using Default) DC 3.5 compact level, 
   cluster1 3.6 level, cluster2 3.5 level
3. edit DC and bump-up compat level to 3.6

Actual results:
operation failure dialog states there should be a cluster list but there's none

Expected results:
either change the sentence or show the list of "problematic" clusters in the
dialog

Additional info:
Comment 1 Yaniv Kaul 2015-12-03 03:24:43 EST
I'm also unsure what the word 'new' means in that dialog box.
Comment 2 Sandro Bonazzola 2016-01-14 02:30:32 EST
Roy, can you take a look?
Comment 3 Sandro Bonazzola 2016-03-11 09:41:16 EST
Doron, I see you targeted this bug to 3.6.6 but it is blocking bug #1285700 which is targeted to 3.6.5. Can this be fixed in 3.6.5 or should we postpone bug #1285700 ?
Comment 4 Sandro Bonazzola 2016-04-06 07:13:31 EDT
dropping block on bug #1285700 since this bug has been targeted to 4.1.
Comment 5 Phillip Bailey 2016-08-08 16:50 EDT
Created attachment 1188911 [details]
New version of error message
Comment 6 Phillip Bailey 2016-08-08 16:54:26 EDT
I didn't see where the list was being omitted. I made the capitalization correction and added a colon between the message and the list. I have attached a screenshot of the new message.

Are you sure that the "new" in the original screenshot wasn't the name of the problematic cluster?
Comment 7 Jiri Belka 2016-08-08 18:38:48 EDT
(In reply to Phillip Bailey from comment #6)
> I didn't see where the list was being omitted. I made the capitalization
> correction and added a colon between the message and the list. I have
> attached a screenshot of the new message.
> 
> Are you sure that the "new" in the original screenshot wasn't the name of
> the problematic cluster?

I can't be sure what was 8 months ago. Move it to ON_QA at least for colon verification ;)
Comment 8 Sandro Bonazzola 2016-12-12 05:57:14 EST
This bug is targeted 4.1 but it appears that the fix has been included in ovirt-engine-4.0.6.3. Please crosscheck and re-target if it's fixed in 4.0.6.
Comment 9 Sandro Bonazzola 2016-12-12 08:59:52 EST
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.
Comment 10 Jiri Belka 2017-01-11 09:17:46 EST
ok, ovirt-engine-webadmin-portal-4.1.0-0.3.beta2.el7.noarch


Error while executing action: Cannot update Data Center compatibility version to a value that is greater than its cluster's version. The following clusters should be upgraded: test.

Note You need to log in before you can comment on or make changes to this bug.