Bug 1287542 - Additional hosts setup using hosted-engine deploy script shows the wrong default value for host_ID
Additional hosts setup using hosted-engine deploy script shows the wrong defa...
Status: CLOSED WONTFIX
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General (Show other bugs)
1.3.0
x86_64 Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Sandro Bonazzola
Ilanit Stein
:
Depends On:
Blocks: Gluster-HC-2
  Show dependency treegraph
 
Reported: 2015-12-02 05:16 EST by SATHEESARAN
Modified: 2015-12-02 07:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEVM 3.6 Beta1 RHEV+RHGS ( Hyperconvergence )
Last Closed: 2015-12-02 07:49:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sasundar: planning_ack?
sasundar: devel_ack?
sasundar: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description SATHEESARAN 2015-12-02 05:16:37 EST
Description of problem:
-----------------------
Configured hosted-engine to run on the RHEL 7.2 hypervisor.
Added one more node using additional host setup procedure of hosted-engine.
While adding the third additional host to the hosted-engine, the default value suggested for host ID was still 2

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHEVM 3.6 beta1
ovirt-hosted-engine-ha-1.3.2.1-1.el7ev.noarch
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch

How reproducible:
-----------------
always

Steps to Reproduce:
-------------------
1. Configure hosted engine to run on host1
2. add one more host to the cluster using additional host setup for hosted engine
3. After second host addition was successful, add one more node
4. This time check for default value of host ID

Actual results:
---------------
The default value of host ID remains to be 2

Expected results:
-----------------
The default value of host ID should be 3

Additional info:
-----------------
[ INFO  ] Installing on additional host
          Please specify the Host ID [Must be integer, default: 2]:
Comment 1 Simone Tiraboschi 2015-12-02 07:49:55 EST
The default is 2 just because it's an additional host so it cannot be 1: it's up to user to choose.
We already check the entered value against the metadata volume but honestly I don't think it's worth to preemptively scan it to find an empty ID.
On the next release we'll have also the capability to deploy additional hosts from the engine and in that case the engine will choose for us.

Note You need to log in before you can comment on or make changes to this bug.