Bug 1287560 - Data Tiering:Don't allow or reset the frequency threshold values to zero when record counter features.record-counter is turned off
Data Tiering:Don't allow or reset the frequency threshold values to zero when...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1284067 1286346
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 05:57 EST by Joseph Elwin Fernandes
Modified: 2016-04-19 03:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286346
Environment:
Last Closed: 2016-04-19 03:49:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-02 06:00:39 EST
REVIEW: http://review.gluster.org/12849 (tier/glusterd : Validation for frequency thresholds and record-counters) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-02 14:47:21 EST
COMMIT: http://review.gluster.org/12849 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 06b7ca1dcd7f3c3187e83a17fad7224d661b4d7e
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Sat Nov 28 17:03:41 2015 +0530

    tier/glusterd : Validation for frequency thresholds and record-counters
    
    1) if record-counters is set to off
       check if both the frequency thresholds are non-zero, then pop
       an error message, with volume set failed.
    2) if record-counters is set to on
       check if both the frequency thresholds are zero, then pop
       an note, but volume set is not failed.
    3) If any of the frequency thresholds are set to a non-zero value,
       switch record-counters on, if not already on
    4) If both the frequency thresholds are set to zero,
       switch record-counters off, if not already off
    
    NOTE: In this fix we have
    1) removed unnecessary ctr vol set options.
    2) changed  ctr_hardlink_heal_expire_period to ctr_lookupheal_link_timeout
    
    Backport of  http://review.gluster.org/12780
    
    > Change-Id: Ie7ccfd3f6e021056905a79de5a3d8f199312f315
    > BUG: 1286346
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    > Reviewed-on: http://review.gluster.org/12780
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: I35621ed3cc1ad20a75ef16e0b95453b8c6120852
    BUG: 1287560
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/12849
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:49:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.