Bug 1287568 - [RFE] [Horizon] SR-IOV support for Horizon
[RFE] [Horizon] SR-IOV support for Horizon
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
9.0 (Mitaka)
Unspecified Unspecified
high Severity medium
: ga
: 9.0 (Mitaka)
Assigned To: Radomir Dopieralski
Ido Ovadia
: FutureFeature
Depends On:
Blocks: 1188000
  Show dependency treegraph
 
Reported: 2015-12-02 06:18 EST by Matthias Runge
Modified: 2017-10-10 22:58 EDT (History)
11 users (show)

See Also:
Fixed In Version: python-django-horizon-9.0.0-4.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 08:13:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1402959 None None None Never

  None (edit)
Description Matthias Runge 2015-12-02 06:18:12 EST
Description of problem:

Currently, there's missing support for that

https://bugs.launchpad.net/horizon/+bug/1402959

https://wiki.openstack.org/wiki/SR-IOV-Passthrough-For-Networking
Comment 2 Itxaka 2015-12-04 09:03:30 EST
Added a BP for "Adding the ability to launch an instance with a pre configured port"
https://blueprints.launchpad.net/horizon/+spec/sriov-support

Patch done for "Adding option to create a port as a tenant"
Comment 3 Itxaka 2016-04-04 07:53:54 EDT
Both Launch instance modals have now the option to attach ports to an instance launch, which enables SR-IOV ports on launch instance.

Available on Mitaka launch.
Comment 7 Rob Young 2016-06-07 14:34:02 EDT
I updated the component tracker but missed the BZ. Will update to OSP 10 here.
Comment 8 Ido Ovadia 2016-06-13 07:20:25 EDT
Verified
========
According to comment 4, has verified on RHOS9 packstack installer

python-django-horizon-9.0.0-4.el7ost.noarch
Comment 10 Rob Young 2016-06-15 15:27:36 EDT
Ack, OK to implement in OSP 9 if all are ready.
Comment 14 errata-xmlrpc 2016-08-11 08:13:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1597.html

Note You need to log in before you can comment on or make changes to this bug.