Bug 1287570 - Fedup (dnf-plugin-system-upgrade) redownloaded all 5143 packages after upgrade failure
Fedup (dnf-plugin-system-upgrade) redownloaded all 5143 packages after upgrad...
Status: CLOSED DUPLICATE of bug 1276886
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 06:22 EST by Andrew Meredith
Modified: 2015-12-02 08:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 08:32:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Meredith 2015-12-02 06:22:00 EST
Description of problem:

The fedup run went all the way to the transaction test and then aborted due to a class between two packages. However, once I had resolved this clash by deleting one of them, the next fedup run downloaded everything again.

Version-Release number of selected component (if applicable):

dnf-plugin-system-upgrade-0.7.0-1.fc22.noarch

How reproducible:

Don't know as I have only done this once so far.

Steps to Reproduce:
1. Have motif-devel and lesstif-devel both installed on F22
2. Run fedup --network 23
3. Wait several hours for the upgrade to fail
4. Remove one of the offending packages
5. Rerun upgrade

Actual results:

The upgrade process redownloads everything

Expected results:

The upgrade process would reuse (most of) the packages it downloaded last time round; bar packages updated in the mean time.
Comment 1 Zbigniew Jędrzejewski-Szmek 2015-12-02 08:32:46 EST
Yeah, we're working on it.

*** This bug has been marked as a duplicate of bug 1276886 ***

Note You need to log in before you can comment on or make changes to this bug.