Bug 128758 - RFE: Add 'switch user' menu item using gdmflexiserver
Summary: RFE: Add 'switch user' menu item using gdmflexiserver
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-menus   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-29 01:33 UTC by Jef Spaleta
Modified: 2008-03-14 14:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 14:09:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jef Spaleta 2004-07-29 01:33:15 UTC
Description of problem:
Provide an intuitive way for people in home computing situations to
switch to a new desktop user without having to logout of the other
user's session.

I think gdmflexiserver as it functions in fedora core 2 is good enough
to be useful as the command to run from a "switch user" menu item.

The only problem I see is the lag in starting up a new gdm login
screen, but functionality using gdmflexiserver seems to act as I would
expect when logging in a new user, switching to existing running
desktops and logging out of a desktop and switching back to an
existing desktop. All without invoking the alt-ctl-# salute to bounce
back and forth. The gdmflexiserver chooser dialog keeps me from having
to use the keyboard shortcut magic.
 
There is probably a corner case when there are N > 2 open desktops and
you logout of a desktop, how do you know which user desktop to go back
to if there are 2 or more remaining.  Other than hacking up
xscreensaver to be able to support moving over to another display I've
no suggestions. But I don't think this is a very large concern. The
alt-ctl-# salute still exists to get out of these situations. 

So I say, put gdmflexiserver into use in a menu item and see how badly
its recieved as a "switch user" utility.

Comment 1 Jef Spaleta 2005-06-07 21:48:15 UTC
There is a project that seems to fit most of the tenants of my original comment.
In case you are still paying attention to this report.

http://ignore-your.tv/fusa/
 Fast User Switch Applet


Comment 2 Ray Strode [halfline] 2005-06-07 22:35:40 UTC
Hi Jef,

I think it's already in the menus.  Although it's a bit broken wrt to console
user , etc.   The desktop core team has discussed the applet before and the
possiblity of including it and fixing all the problems that get caused by having
more than one user logged in at the same time.  Note, xscreensaver has a New
Login button also (not enabled by default).

Comment 3 Jef Spaleta 2005-06-08 00:31:21 UTC
holy crap thats great!
In the menus in rawhide?
Can i re-enable the login button in xscreensaver in rawhide?

I'm more than happy to poke around at this and give more feedback.

multiple users on the box at the same time has a number of console user
permission issues, to be sure.  I'd love to spend some time running into more of
them and hurting myself.

-jef

Comment 4 Ray Strode [halfline] 2005-06-08 14:52:56 UTC
Hi Jef,

Hat -> System Tools -> New Login

The xscreensaver thing is a compile time option, so you'd have to recompile the
src rpms after changing the spec file.

getting multiple user login to work well is a project we've discussed before. 
The FC5 development cycle has just started, so it'll no doubt come up again as
potential project to work on.

Comment 5 Matthias Clasen 2008-03-14 14:09:56 UTC
This has been fixed a long time ago.


Note You need to log in before you can comment on or make changes to this bug.