Bug 1287583 - Data Tiering:Read heat not getting calculated and read operations not heating the file with counter enabled
Data Tiering:Read heat not getting calculated and read operations not heating...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
:
Depends On: 1286654 1286656
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 06:37 EST by Joseph Elwin Fernandes
Modified: 2016-06-19 20:00 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286656
Environment:
Last Closed: 2016-04-19 03:49:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-02 06:38:39 EST
REVIEW: http://review.gluster.org/12850 (tier/libgfdb/sql: Correcting logic in sql query for read) posted (#1) for review on master by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-02 08:12:00 EST
REVIEW: http://review.gluster.org/12855 (tier/libgfdb/sql: Correcting logic in sql query for read) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 3 Vijay Bellur 2015-12-03 05:34:00 EST
REVIEW: http://review.gluster.org/12855 (tier/libgfdb/sql: Correcting logic in sql query for read) posted (#2) for review on release-3.7 by Joseph Fernandes
Comment 4 Vijay Bellur 2015-12-03 05:41:14 EST
REVIEW: http://review.gluster.org/12868 (tier/libgfdb/sql: Correcting logic in sql query for read) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 5 Vijay Bellur 2015-12-04 19:47:05 EST
COMMIT: http://review.gluster.org/12868 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit d5df0db18b29b1db2577ac5ed388966c0eb203b0
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Mon Nov 30 16:51:35 2015 +0530

    tier/libgfdb/sql: Correcting logic in sql query for read
    
    Correcting query in the  where clause
    
    from "a & b | c"
    
    to "a & (b | c)"
    
    where "a" is the condition to join the gf_file_tb and gf_flink_tb
    through gfids
    
    "b" is the condition for the write heat
    and "c" is the condition for read heat
    
    Backport of http://review.gluster.org/12823
    
    > Change-Id: I99226d82b0efb68fbef3a40f02b215bb2b4370d6
    > BUG: 1286656
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    > Reviewed-on: http://review.gluster.org/12823
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: I70533c8589a6cd67e8737e110af0a23abed9013d
    BUG: 1287583
    Reviewed-on: http://review.gluster.org/12868
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 6 Kaushal 2016-04-19 03:49:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.