Bug 1287586 - [RFE] [Horizon] support domain scoped tokens in horizon
Summary: [RFE] [Horizon] support domain scoped tokens in horizon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-openstack-auth
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 10.0 (Newton)
Assignee: Radomir Dopieralski
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks: 1334442 1335593 1359509 1360940 1363699 1370471 1370472 1394653
TreeView+ depends on / blocked
 
Reported: 2015-12-02 11:45 UTC by Matthias Runge
Modified: 2016-12-14 15:18 UTC (History)
16 users (show)

Fixed In Version: python-django-openstack-auth-2.2.0-1.el7ost
Doc Type: Enhancement
Doc Text:
With this enhancement, domain-scoped tokens can be used to login to the Dashboard (horizon). This was added to fully support the management of identity in keystone v3 when using a richer role set, where a domain-scoped token is required. django_openstack_auth must support obtaining and maintaining this type of token for the session. As a result, horizon support for domain-scoped tokens has been available since Red Hat OpenStack Platform 9.
Clone Of:
: 1370471 1370472 (view as bug list)
Environment:
Last Closed: 2016-12-14 15:18:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Matthias Runge 2015-12-02 11:45:24 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Mike McCune 2016-03-28 23:09:17 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 6 Rob Young 2016-06-17 16:49:06 UTC
I am OK moving this to OSP 9 if dev, QE, docs can manage it. I set it for OSP 10 because it was medium priority and we were trying to minimize the high priority features we included in OSP 9. If we have the bandwidth to add in 10, we can do so.

Comment 10 Rob Young 2016-08-25 14:21:45 UTC
Hi Irina, 

I agree with your assessment, but have handed Horizon off to Anandeep. Please work with him on this.

The issue here may be QE, doc and support readiness in OSP 9 vs OSP 10. If all areas are ready in OSP 9, I agree that the BZ can be set accordingly.

I have no additional insight or information that would move a decision otherwise.

Thanks, Rob

Comment 13 Dan Trainor 2016-12-09 20:30:53 UTC
After review, this functionality appears to be present once enabled.

Comment 15 errata-xmlrpc 2016-12-14 15:18:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.