Bug 1287613 - blkid doesn't recognize PPC PRePboot partition
blkid doesn't recognize PPC PRePboot partition
Status: CLOSED DUPLICATE of bug 1287611
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: util-linux (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Karel Zak
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 08:03 EST by Alexander Todorov
Modified: 2015-12-03 07:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1287611
: 1287734 (view as bug list)
Environment:
Last Closed: 2015-12-03 07:24:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2015-12-02 08:03:22 EST
+++ This bug was initially created as a clone of Bug #1287611 +++

Description of problem:

I have /dev/sda1 which is a PPC PRePboot partition and blkid only shows the UUID for it:

# blkid
/dev/dm-0: UUID="b87d36ec-9447-4bdb-ba77-5002c5d984ba" TYPE="xfs" 
/dev/block/253:0: UUID="b87d36ec-9447-4bdb-ba77-5002c5d984ba" TYPE="xfs" 
/dev/block/8:3: UUID="iYsRbf-tK9F-DNlR-gk24-0IIC-2Yaf-zEkfQU" TYPE="LVM2_member" PARTUUID="147a529e-2db6-4935-b189-0507445ec419" 
/dev/sda2: UUID="3458bc17-4116-4b3c-9bc6-c792f5014fbc" TYPE="xfs" PARTUUID="178d8db4-ac52-4a7c-9176-d14f2357164b" 
/dev/block/8:2: UUID="3458bc17-4116-4b3c-9bc6-c792f5014fbc" TYPE="xfs" PARTUUID="178d8db4-ac52-4a7c-9176-d14f2357164b" 
/dev/dm-1: UUID="f15b4e36-9f0c-40ec-bb6a-fb6f8c2023a8" TYPE="swap" 
/dev/block/253:1: UUID="f15b4e36-9f0c-40ec-bb6a-fb6f8c2023a8" TYPE="swap" 
/dev/sda1: PARTUUID="5b0fcc94-2b8c-4ceb-819a-edca343b1549" 
/dev/mapper/rhel_ibm--p8--03--lp4-home: UUID="3a5d6d46-4dc1-4894-a150-ad772e3e8f9c" TYPE="xfs" 


# fdisk -l
WARNING: fdisk GPT support is currently new, and therefore in an experimental phase. Use at your own discretion.

Disk /dev/sda: 80.5 GB, 80530636800 bytes, 157286400 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: gpt


#         Start          End    Size  Type            Name
 1         2048        10239      4M  unknown         
 2        10240      1034239    500M  Microsoft basic 
 3      1034240    157284351   74,5G  Linux LVM       

... skip ....

# parted -l
Model: AIX VDASD (scsi)
Disk /dev/sda: 80,5GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: pmbr_boot

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  5243kB  4194kB                     prep
 2      5243kB  530MB   524MB   xfs
 3      530MB   80,5GB  80,0GB                     lvm


... skip ...



Version-Release number of selected component (if applicable):
util-linux-2.23.2-26.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install a ppc64 or ppc64le system.
2. Selected automatic partitioning.
3.

Actual results:
blkid doesn't give us any indication that sda1 is a PRePboot partition.

Expected results:
The opposite. 

Additional info:

I'm working on a test which uses blkid output and this is a corner case which isn't covered. blkid is very handy in bash scripts and we need it to somehow identify PRePboot partitions.
Comment 1 Karel Zak 2015-12-03 07:24:42 EST

*** This bug has been marked as a duplicate of bug 1287611 ***

Note You need to log in before you can comment on or make changes to this bug.