Bug 1287618 - Wrong definition of default value in man page logind.conf
Wrong definition of default value in man page logind.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: systemd-maint
Branislav Blaškovič
: EasyFix
Depends On:
Blocks: 1289485 1313485
  Show dependency treegraph
 
Reported: 2015-12-02 08:06 EST by Radka Skvarilova
Modified: 2016-11-03 20:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: systemd-219-20.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 20:48:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radka Skvarilova 2015-12-02 08:06:02 EST
Description of problem:
After fixing bug https://bugzilla.redhat.com/show_bug.cgi?id=1286031 was changed the default value for RemoveIPC from "yes" to "no", but in man page is still default "yes".

Version-Release number of selected component (if applicable):
systemd-219-19.el7_2.2.x86_64

How reproducible:
always

Steps to Reproduce:
1. man longind.conf
2. Check if the Default value for RemoveIPC is set to "no"
3.

Actual results:
Defaults to "yes".

Expected results:
Defaults to "no".

Additional info:
Comment 1 Lukáš Nykrýn 2016-01-25 07:59:54 EST
fixed in systemd-219-19.el7_2.3
Comment 4 Branislav Blaškovič 2016-08-17 10:23:48 EDT
systemd-219-26.el7.x86_64:
       RemoveIPC=
           Controls whether System V and POSIX IPC objects belonging to the user shall be removed when the user fully logs out. Takes a boolean argument. If enabled, the user may not consume IPC resources
           after the last of the user's sessions terminated. This covers System V semaphores, shared memory and message queues, as well as POSIX shared memory and message queues. Note that IPC objects of
           the root user are excluded from the effect of this setting. Defaults to "no".


systemd-219-19.el7.x86_64
       RemoveIPC=
           Controls whether System V and POSIX IPC objects belonging to the user shall be removed when the user fully logs out. Takes a boolean argument. If enabled, the user may not consume IPC resources
           after the last of the user's sessions terminated. This covers System V semaphores, shared memory and message queues, as well as POSIX shared memory and message queues. Note that IPC objects of
           the root user are excluded from the effect of this setting. Defaults to "yes".

I am not writing a test for this, switching to verified.
Comment 6 errata-xmlrpc 2016-11-03 20:48:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2216.html

Note You need to log in before you can comment on or make changes to this bug.