Bug 1287635 - Attached volume for Openstack instance could show up as swap or ephemeral disk
Attached volume for Openstack instance could show up as swap or ephemeral disk
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Ladislav Smola
Ola Pavlenko
openstack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 08:15 EST by Marius Cornea
Modified: 2017-08-29 23:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:15:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-12-02 08:15:31 EST
Description of problem:
When attaching a volume to an instance which has no swap or ephemeral disk assigned the volume shows up in the list of of disks as swap or ephemeral.

Version-Release number of selected component (if applicable):
5.5.0.12-rc2.20151124135609_653c0d4

How reproducible:
100% 

Steps to Reproduce:
1. Spawn an Openstack instance that has no swap or ephemeral disk 
2. Attach a volume to it
3. Check the instance list of disks 

Actual results:
The volume shows up in the list of swap or ephemeral disks.

Expected results:
The volume should be shown as a volume disk.
Comment 3 CFME Bot 2015-12-08 18:47:05 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/1b304f0722fde42fdf6ea2ff9e2afa2e32a6babe

commit 1b304f0722fde42fdf6ea2ff9e2afa2e32a6babe
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Wed Dec 2 14:03:31 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Thu Dec 3 18:05:01 2015 +0100

    Do not store empty disks
    
    Disks are not really created and mounted. The mounpoint is used for
    comparing with attached volumes, so by storing empty disks we
    are showing the relation badly. The mountpoint is mandatory column
    so we cannot store disks without it.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1287635

 .../openstack/cloud_manager/refresh_parser.rb      |  6 +++---
 .../openstack/cloud_manager/refresh_spec_common.rb | 22 +++++++++++++++++-----
 2 files changed, 20 insertions(+), 8 deletions(-)
Comment 4 Ronnie Rasouli 2016-06-14 04:01:47 EDT
Tested with an instance that disk attached to it, it does not show swap or ephemeral assigned
Comment 6 errata-xmlrpc 2016-06-29 11:15:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.