This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1287677 - class name of lbaasv2 is not working in neutron.conf
class name of lbaasv2 is not working in neutron.conf
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Ihar Hrachyshka
Toni Freger
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 08:46 EST by Alexander Stafeyev
Modified: 2016-06-29 09:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-neutron-7.0.4-1.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the lbaasv2 stevedore entry point was not registered in the neutron.service_plugins namespace. This would cause neutron-server to fail if the lbaasv2 alias was used in the service_plugins option instead of the full Python import path to the plug-in. With this update, the missing stevedore alias was added to the package, allowing neutron-server to load the lbaasv2 plug-in using the alias.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 09:59:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1517125 None None None Never
OpenStack gerrit 250822 None None None Never

  None (edit)
Description Alexander Stafeyev 2015-12-02 08:46:53 EST
Description of problem:
In neutron.conf 
# service_plugins =
service_plugins =router,lbaasv2 

this config makes neutron-server to fail, while 

# service_plugins =
service_plugins =router,neutron_lbaas.services.loadbalancer.plugin.LoadBalancerPluginv2

work well.

Version-Release number of selected component (if applicable):
openstack-neutron-bigswitch-lldp-2015.1.38-1.el7ost.noarch
openstack-neutron-openvswitch-2015.1.2-2.el7ost.noarch
openstack-neutron-metering-agent-2015.1.2-2.el7ost.noarch
openstack-neutron-2015.1.2-2.el7ost.noarch
openstack-neutron-common-2015.1.2-2.el7ost.noarch
openstack-neutron-lbaas-2015.1.2-1.el7ost.noarch
openstack-neutron-ml2-2015.1.2-2.el7ost.noarch
python-neutron-lbaas-2015.1.2-1.el7ost.noarch
python-neutronclient-2.4.0-2.el7ost.noarch
python-neutron-2015.1.2-2.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1.enable Lbaasv2 with lbaasv2 class-name in neutron.conf file. 
2.
3.

Actual results:
neutron-server service fails 

Expected results:
neutron-server service should work

Additional info:
logs        http://pastebin.com/CzBRbNxU   

I believe the same issue exists in Liberty ( did not check)
Comment 3 Ihar Hrachyshka 2016-01-07 06:17:16 EST
Will be fixed in the next Liberty release: https://review.openstack.org/#/c/250822/
Comment 4 Mike McCune 2016-03-28 18:42:18 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Assaf Muller 2016-06-04 16:00:36 EDT
(In reply to Ihar Hrachyshka from comment #3)
> Will be fixed in the next Liberty release:
> https://review.openstack.org/#/c/250822/

I imagine there's been an upstream stable/liberty release since January. We should rebase and release an updated OSP 8. Can you please chase this down with Nir?
Comment 6 Ihar Hrachyshka 2016-06-07 08:08:08 EDT
Assaf, we should solve the issue of rebases not happening in OSP irrespective to the bug.

As for the bug itself, our latest releases for OSP8 include the patch, since we base on 7.0.4.
Comment 8 Toni Freger 2016-06-27 11:48:04 EDT
neutron conf with below configuration restarted well.
neutron.conf 
# service_plugins =
service_plugins =router,lbaasv2 
(tested on openstack-neutron-7.0.4-7.el7ost.noarch)
Comment 10 errata-xmlrpc 2016-06-29 09:59:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1353

Note You need to log in before you can comment on or make changes to this bug.