Bug 1287685 - modifyrepo --compress-type xz tracebacks on empty file
modifyrepo --compress-type xz tracebacks on empty file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: createrepo (Show other bugs)
7.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Michal Domonkos
Eva Mrakova
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 08:56 EST by Stanislav Zidek
Modified: 2017-08-01 18:16 EDT (History)
3 users (show)

See Also:
Fixed In Version: createrepo-0.9.9-28.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 18:16:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Zidek 2015-12-02 08:56:10 EST
Description of problem:
modifyrepo --compress-type xz tracebacks on empty file

Version-Release number of selected component (if applicable):
createrepo-0.9.9-23.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. mkdir x && cd x/
2. createrepo .
3. touch empty
4. modifyrepo --compress-type xz empty repodata/

Actual results:
Traceback (most recent call last):
  File "/usr/share/createrepo/modifyrepo.py", line 234, in <module>
    ret = main(sys.argv[1:])
  File "/usr/share/createrepo/modifyrepo.py", line 227, in main
    repomd.add(metadata, mdtype=opts.mdtype)
  File "/usr/share/createrepo/modifyrepo.py", line 126, in add
    newmd.write(md)
LZMA.error: unknown error!

Expected results:
no traceback
Comment 6 errata-xmlrpc 2017-08-01 18:16:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2024

Note You need to log in before you can comment on or make changes to this bug.