This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1287718 - [abrt] xfce4-settings: convert_xfce_output_info(): xfce4-display-settings killed by SIGSEGV
[abrt] xfce4-settings: convert_xfce_output_info(): xfce4-display-settings kil...
Status: CLOSED DUPLICATE of bug 1317382
Product: Fedora
Classification: Fedora
Component: xfce4-settings (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:41546a25327b7a3796ed5360aac...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 09:23 EST by Vitor
Modified: 2016-05-19 07:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-19 07:05:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (49.80 KB, text/plain)
2015-12-02 09:23 EST, Vitor
no flags Details
File: cgroup (348 bytes, text/plain)
2015-12-02 09:23 EST, Vitor
no flags Details
File: core_backtrace (24.51 KB, text/plain)
2015-12-02 09:23 EST, Vitor
no flags Details
File: dso_list (8.34 KB, text/plain)
2015-12-02 09:23 EST, Vitor
no flags Details
File: environ (1.13 KB, text/plain)
2015-12-02 09:23 EST, Vitor
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-02 09:23 EST, Vitor
no flags Details
File: maps (43.41 KB, text/plain)
2015-12-02 09:23 EST, Vitor
no flags Details
File: mountinfo (3.42 KB, text/plain)
2015-12-02 09:24 EST, Vitor
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-02 09:24 EST, Vitor
no flags Details
File: open_fds (550 bytes, text/plain)
2015-12-02 09:24 EST, Vitor
no flags Details
File: proc_pid_status (1019 bytes, text/plain)
2015-12-02 09:24 EST, Vitor
no flags Details
File: var_log_messages (28 bytes, text/plain)
2015-12-02 09:24 EST, Vitor
no flags Details

  None (edit)
Description Vitor 2015-12-02 09:23:44 EST
Description of problem:
Trying to open display option.

Version-Release number of selected component:
xfce4-settings-4.12.0-5.fc22

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        xfce4-display-settings
crash_function: convert_xfce_output_info
executable:     /usr/bin/xfce4-display-settings
global_pid:     14783
kernel:         4.2.6-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 convert_xfce_output_info at main.c:1618
 #1 list_connected_outputs at main.c:1786
 #2 on_area_paint at main.c:2589
 #7 foo_scroll_area_expose at scrollarea.c:522
 #8 _gtk_marshal_BOOLEAN__BOXED at gtkmarshalers.c:86
 #13 gtk_widget_event_internal at gtkwidget.c:5017
 #14 gtk_widget_send_expose at gtkwidget.c:4846
 #15 gtk_container_propagate_expose at gtkcontainer.c:2757
 #16 gtk_container_expose at gtkcontainer.c:2661
 #17 _gtk_marshal_BOOLEAN__BOXED at gtkmarshalers.c:86
Comment 1 Vitor 2015-12-02 09:23:49 EST
Created attachment 1101492 [details]
File: backtrace
Comment 2 Vitor 2015-12-02 09:23:51 EST
Created attachment 1101494 [details]
File: cgroup
Comment 3 Vitor 2015-12-02 09:23:53 EST
Created attachment 1101497 [details]
File: core_backtrace
Comment 4 Vitor 2015-12-02 09:23:54 EST
Created attachment 1101499 [details]
File: dso_list
Comment 5 Vitor 2015-12-02 09:23:56 EST
Created attachment 1101501 [details]
File: environ
Comment 6 Vitor 2015-12-02 09:23:57 EST
Created attachment 1101503 [details]
File: limits
Comment 7 Vitor 2015-12-02 09:23:59 EST
Created attachment 1101504 [details]
File: maps
Comment 8 Vitor 2015-12-02 09:24:00 EST
Created attachment 1101505 [details]
File: mountinfo
Comment 9 Vitor 2015-12-02 09:24:02 EST
Created attachment 1101506 [details]
File: namespaces
Comment 10 Vitor 2015-12-02 09:24:03 EST
Created attachment 1101507 [details]
File: open_fds
Comment 11 Vitor 2015-12-02 09:24:04 EST
Created attachment 1101508 [details]
File: proc_pid_status
Comment 12 Vitor 2015-12-02 09:24:06 EST
Created attachment 1101509 [details]
File: var_log_messages
Comment 13 Kevin Fenzi 2015-12-02 11:18:30 EST
This happens everytime? 

Did it work as expected in the past?

Do you have multiple monitors? docking station?
Comment 14 Vitor 2015-12-02 11:27:32 EST
(In reply to Kevin Fenzi from comment #13)
> This happens everytime? 
> 
> Did it work as expected in the past?
> 
> Do you have multiple monitors? docking station?

Yes, everytime.

Never tried before. Just tried to open Display options.

No monitor on PC. Connecting through VNC, but on my laptop I have dock and multiple monitors.

Regards
Vitor Jr.
Comment 15 Kevin Fenzi 2015-12-02 17:45:19 EST
ok, to be clear: this is in the vnc session? Or locally?
Comment 16 Richard W.M. Jones 2016-05-19 07:05:53 EDT
Closing as duplicate of a newer bug that has more details.

*** This bug has been marked as a duplicate of bug 1317382 ***

Note You need to log in before you can comment on or make changes to this bug.