Bug 1287723 - Handle Rsync/Tar errors effectively
Handle Rsync/Tar errors effectively
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Aravinda VK
:
Depends On:
Blocks: 1313309
  Show dependency treegraph
 
Reported: 2015-12-02 09:25 EST by Aravinda VK
Modified: 2016-06-16 09:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1313309 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:47:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2015-12-02 09:25:52 EST
Description of problem:
When Changelogs processed in Batch, Geo-rep logs all the GFIDs from that batch as SKIPPED even when a few GFIDs from the batch failed to sync.


Steps to Reproduce: (Reproduced by introducing GFID conflict)
1. Create a file in Slave mount(say f1)
2. Create files in Master mount and add data to it
   echo "Hello" > f1; echo "Hello" > f2; echo "Hello" > f3;
3. All the files Create and Data will be recorded in single changelog. Rsync/Tar skips f1 but syncs f2 and f3. But it logs GFIDs of f1, f2 and f3 as SKIPPED.

Actual results:
Logs all the GFIDs as failure.

Expected results:
Only failures should be reported in log.
Comment 1 Vijay Bellur 2015-12-02 09:28:22 EST
REVIEW: http://review.gluster.org/12856 (geo-rep: Handling Rsync/Tar errors efficiently) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 2 Vijay Bellur 2015-12-02 09:35:39 EST
REVIEW: http://review.gluster.org/12856 (geo-rep: Handling Rsync/Tar errors efficiently) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 3 Vijay Bellur 2016-02-26 05:15:14 EST
COMMIT: http://review.gluster.org/12856 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit d136a789258e8f600e536717da156a242d8ed9a5
Author: Aravinda VK <avishwan@redhat.com>
Date:   Wed Dec 2 19:37:55 2015 +0530

    geo-rep: Handling Rsync/Tar errors efficiently
    
    Geo-rep processes Changelogs in Batch, if one file in batch
    fails with rsync error that Changelog file is reprocessed multiple times.
    After MAX_RETRY, it logs all the GFIDs from that batch as Skipped.
    
    This patch addresses following issues,
    1. When Rsync/Tar fails do not parse Changelog again for retry
    2. When Rsync/Tar fails do not replay Entry operations, only retry
       rsync/tar for those GFIDs
    3. Log Error in Rsync/Tar only in the last Retry
    4. Do not log Skipped GFIDs since Rsync/Tar errors are logged for
       only failed files.
    5. Changed Entry failures as Error instead of Warning
    
    BUG: 1287723
    Change-Id: Ie134ce2572693056ab9b9008cd8aa5b5d87f7975
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/12856
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:47:58 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.