Bug 1287729 - python-dockerpty requires python2 and python3
python-dockerpty requires python2 and python3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-dockerpty (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Miller
Tomas Tomecek
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 09:37 EST by Michael Scherer
Modified: 2016-04-06 10:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-dockerpty-0.4.1-2.fc23 python-dockerpty-0.4.1-2.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 10:08:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Scherer 2015-12-02 09:37:58 EST
Description of problem:

$ rpm -q --requires python-dockerpty
python(abi) = 2.7
python-docker-py
python-six
python3-docker-py
python3-six
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

$ rpm -ql python-dockerpty
/usr/lib/python2.7/site-packages/dockerpty
/usr/lib/python2.7/site-packages/dockerpty-0.3.3-py2.7.egg-info
/usr/lib/python2.7/site-packages/dockerpty-0.3.3-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/dockerpty-0.3.3-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/dockerpty-0.3.3-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/dockerpty-0.3.3-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/dockerpty-0.3.3-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/dockerpty/__init__.py
/usr/lib/python2.7/site-packages/dockerpty/__init__.pyc
/usr/lib/python2.7/site-packages/dockerpty/__init__.pyo
/usr/lib/python2.7/site-packages/dockerpty/io.py
/usr/lib/python2.7/site-packages/dockerpty/io.pyc
/usr/lib/python2.7/site-packages/dockerpty/io.pyo
/usr/lib/python2.7/site-packages/dockerpty/pty.py
/usr/lib/python2.7/site-packages/dockerpty/pty.pyc
/usr/lib/python2.7/site-packages/dockerpty/pty.pyo
/usr/lib/python2.7/site-packages/dockerpty/tty.py
/usr/lib/python2.7/site-packages/dockerpty/tty.pyc
/usr/lib/python2.7/site-packages/dockerpty/tty.pyo
/usr/share/doc/python-dockerpty
/usr/share/doc/python-dockerpty/LICENSE.txt
/usr/share/doc/python-dockerpty/MANIFEST.in
/usr/share/doc/python-dockerpty/README.md


Since there is only python 2 files in the rpm, it shouldn't requires python2 and python3 modules.

Version-Release number of selected component (if applicable):
# rpm -q python-dockerpty
python-dockerpty-0.3.3-3.fc23.noarch
Comment 1 Tomas Tomecek 2016-03-08 12:49:58 EST
Fixed by http://pkgs.fedoraproject.org/cgit/rpms/python-dockerpty.git/commit/?id=8c834c0aba29ee255165e4b399c6499ad7f7b497

will provide build for f23 too
Comment 2 Fedora Update System 2016-03-08 12:54:09 EST
python-dockerpty-0.4.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f3277d4bb
Comment 3 Fedora Update System 2016-03-09 17:56:08 EST
python-dockerpty-0.4.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f3277d4bb
Comment 4 Fedora Update System 2016-03-11 08:25:22 EST
python-dockerpty-0.4.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2016-03-30 13:54:23 EDT
python-dockerpty-0.4.1-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d3f470fb42
Comment 6 Fedora Update System 2016-04-01 16:57:52 EDT
python-dockerpty-0.4.1-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d3f470fb42
Comment 7 Fedora Update System 2016-04-06 10:08:36 EDT
python-dockerpty-0.4.1-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.