Bug 1287731 - VMware provider refresh fails with 'divided by 0'
VMware provider refresh fails with 'divided by 0'
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.4.5
Assigned To: Adam Grare
Alex Newman
ems_refresh:vmware
: ZStream
Depends On: 1282851
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 09:38 EST by Greg Blomquist
Modified: 2016-03-29 10:15 EDT (History)
12 users (show)

See Also:
Fixed In Version: 5.4.5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1282851
Environment:
Last Closed: 2016-03-29 10:15:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Adam Grare 2015-12-02 11:20:27 EST
Root cause was having a VC >= 5.0 and VMs on hosts <= 4.1.  The numCoresPerSocket property was added in 5.0 [1] so the VC just set that value to 0 for any hosts older than 5.0.

[1] https://www.vmware.com/support/developer/converter-sdk/conv55_apireference/vim.vm.VirtualHardware.html
Comment 4 Alex Newman 2016-03-18 17:00:31 EDT
Verified w/ 5.1u3
Server Name 	EVM
Version 	5.4.5.2.20160315175001_800759c
User Name 	Administrator
User Role 	EvmRole-super_administrator
Browser 	Firefox
Browser Version 	38
Browser OS 	Linux
Comment 6 errata-xmlrpc 2016-03-29 10:15:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0171.html

Note You need to log in before you can comment on or make changes to this bug.