Bug 1287743 - -specs=/usr/lib/rpm/redhat/redhat-hardened-ld breaks -static [NEEDINFO]
-specs=/usr/lib/rpm/redhat/redhat-hardened-ld breaks -static
Status: CLOSED DUPLICATE of bug 1343892
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Florian Festi
Fedora Extras Quality Assurance
: Regression
: 1202091 (view as bug list)
Depends On: 1192183
Blocks: harden-failure 1202091
  Show dependency treegraph
 
Reported: 2015-12-02 10:09 EST by Kamil Dudka
Modified: 2016-11-24 06:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-08 05:50:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kdudka: needinfo? (ffesti)


Attachments (Terms of Use)

  None (edit)
Description Kamil Dudka 2015-12-02 10:09:32 EST
Description of problem:
With -specs=/usr/lib/rpm/redhat/redhat-hardened-ld in LDFLAGS it is no longer possible to statically link the C run-time.  I see no way to work around this breakage, except removing -specs=/usr/lib/rpm/redhat/redhat-hardened-ld from LDFLAGS.


Version-Release number of selected component (if applicable):
redhat-rpm-config-36-1.fc23.noarch


Steps to Reproduce:
$ printf 'int main() { }\n' | gcc -xc - -static
$ printf 'int main() { }\n' | gcc -xc - -static -specs=/usr/lib/rpm/redhat/redhat-hardened-ld
/usr/bin/ld: /usr/lib/gcc/x86_64-redhat-linux/5.1.1/../../../../lib64/libc.a(libc-start.o): relocation R_X86_64_32 against `_dl_starting_up' can not be used when making a shared object; recompile with -fPIC
/usr/lib/gcc/x86_64-redhat-linux/5.1.1/../../../../lib64/libc.a: error adding symbols: Bad value
collect2: error: ld returned 1 exit status
Comment 1 Kamil Dudka 2016-02-12 04:03:51 EST
No reply for two months.  Is this package still actively maintained?
Comment 2 Panu Matilainen 2016-11-08 05:50:14 EST
Marking as duplicate of bug 1343892 which has more information and a possible fix.

*** This bug has been marked as a duplicate of bug 1343892 ***
Comment 3 Richard W.M. Jones 2016-11-24 06:55:01 EST
*** Bug 1202091 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.