Bug 1287752 - find_elf_note invalid read if setenv has been called before libproc init
find_elf_note invalid read if setenv has been called before libproc init
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: procps-ng (Show other bugs)
7.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Rybar
Jan Houska
: Patch, Upstream
Depends On:
Blocks: 1163404 1305230
  Show dependency treegraph
 
Reported: 2015-12-02 10:29 EST by Branislav Náter
Modified: 2016-11-04 02:36 EDT (History)
7 users (show)

See Also:
Fixed In Version: procps-ng-3.3.10-8.el7
Doc Type: Bug Fix
Doc Text:
Previously, behavior of the libproc library was unreliable when it was loaded with the dlopen() call after the environment was changed with the setenv() call. As a consequence, an invalid memory access error could occur in libproc. With this update, the find_elf_note() function obtains the auxiliary vector values using a different and safer method based on parsing the /proc/self/auxv file, and the described problem no longer occurs.
Story Points: ---
Clone Of: 1163404
Environment:
Last Closed: 2016-11-04 02:36:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
procps-ng-3.3.10-find_elf_note-memory-error-fix.patch (1.99 KB, patch)
2016-01-14 07:57 EST, Jaromír Cápík
no flags Details | Diff
Modified patch resolving obtaining of env. variables. (2.08 KB, patch)
2016-07-07 08:10 EDT, Jan Rybar
no flags Details | Diff

  None (edit)
Comment 2 Jaromír Cápík 2016-01-14 07:57 EST
Created attachment 1114795 [details]
procps-ng-3.3.10-find_elf_note-memory-error-fix.patch
Comment 3 Jaromír Cápík 2016-01-14 08:15:24 EST
Fixed in Fedora rawhide (f24).
Comment 6 Jan Rybar 2016-07-07 08:10 EDT
Created attachment 1177260 [details]
Modified patch resolving obtaining of env. variables.
Comment 11 errata-xmlrpc 2016-11-04 02:36:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2447.html

Note You need to log in before you can comment on or make changes to this bug.