Bug 1287801 - Not detecting new displays when attached
Not detecting new displays when attached
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 12:31 EST by Wayne Walker
Modified: 2016-12-20 11:35 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 11:35:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Walker 2015-12-02 12:31:43 EST
Description of problem:
When I attach external displays to my MBP, running Fedora in VMware Fusion, no new displays are detected.  This only began today after the upgrade to Fedora 23.  Worked fine for a year on Fedora 21 and Fedora 22.


Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.18.0-2.fc23.x86_64
xorg-x11-server-utils-7.7-17.fc23.x86_64
kernel-4.2.6-301.fc23.x86_64
open-vm-tools-10.0.0-7.fc23.x86_64
How reproducible:
100%

Steps to Reproduce:
1. Install Fedora 23 in VMware Fusion 8.
2. Select the VM in VMware, click View -> Use All Displays in Full Screen
3. In VM, go to full screen mode.
4. xrandr - Virtual 1
5. Add external monitors.
6. xrandr - Still only Virtual 1

Actual results:
xrandr (and other tools like xfce4-display-settings) see only 1 attached display, Virtual 1.

Expected results:
Virtual 1
Virtual 2
Virtual 3


Additional info:
Comment 1 Wayne Walker 2015-12-02 12:32:47 EST
Also tested with the legacy vmware tools from VMware (although they recommend open-vm-tools).
Comment 2 Wayne Walker 2015-12-02 16:07:00 EST
Tried running off the F22 kernel that was working yesterday.  No joy.
Comment 3 Wayne Walker 2015-12-02 17:06:43 EST
OK, I've fixed it.

I did a fresh install, verified it worked, dnf update, verified it still worked then diffed the rpms.

One needs not only open-vm-tools, but also open-vm-tools-desktop.

Splitting these two packages will cause a lot of problems for people.
Comment 4 Fedora End Of Life 2016-11-24 08:56:00 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2016-12-20 11:35:27 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.