Bug 1287818 - 100% CPU usage in Yelp after searching
100% CPU usage in Yelp after searching
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
24
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 13:37 EST by Christian Stadelmann
Modified: 2016-08-29 03:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-29 03:54:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 661509 None None None Never

  None (edit)
Description Christian Stadelmann 2015-12-02 13:37:09 EST
Description of problem:
Note: This bug report is a clone of #1184646 which was closed wrongly.

Version-Release number of selected component (if applicable):
Present since at least 3.12.x, see https://bugzilla.gnome.org/show_bug.cgi?id=744636
Still present in:
yelp-3.17.2-3.fc23.x86_64
gtk3-3.18.5-3.fc23.x86_64
glib2-2.46.2-1.fc23.x86_64

Steps to reproduce:
1. open yelp
2. press the search button in GtkHeaderBar
3. search for some string
4. close yelp

How reproducible:
always

Actual results:
100% CPU usage on one core after step 3. Yelp process will never exit until you manually kill it or logout/reboot. 

Expected results:
No busy loop. Yelp should exit when closing.

Additional info:
See the original report [1] which also includes a backtrace of gdb attached to yelp. See upstream bug reports https://bugzilla.gnome.org/show_bug.cgi?id=661509 and https://bugzilla.gnome.org/show_bug.cgi?id=744636

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1184646
Comment 1 Christian Stadelmann 2016-02-06 17:19:50 EST
Upstream bug report states that this issue is fixed in 3.18.x, but Fedora is still shipping 3.17.2 due to the workaround chosen for bug #1276226. Once its upstream pendant https://bugzilla.gnome.org/show_bug.cgi?id=753443 is fixed, yelp can be updated to 3.18.x or 3.20.x and this issue will be gone.
Comment 2 Christian Stadelmann 2016-08-29 03:54:01 EDT
This issue is fixed upstream and landed in 3.20.x and newer.

Note You need to log in before you can comment on or make changes to this bug.