Bug 1287839 - OPM kilo needs puppet-neutron notifications backports
OPM kilo needs puppet-neutron notifications backports
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
All Linux
urgent Severity urgent
: z3
: 7.0 (Kilo)
Assigned To: Ivan Chavero
Ofer Blaut
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 14:32 EST by Emilien Macchi
Modified: 2015-12-21 12:12 EST (History)
5 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2015.1.8-31.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 12:12:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emilien Macchi 2015-12-02 14:32:58 EST
Description of problem:
We're trying to backport a patch[1] in OSP-d 7:
"neutron: enable nova-event-callback by default".
[1] https://review.openstack.org/#/c/225962/

But the patch can't work because we need https://review.openstack.org/#/c/235316/ and https://review.openstack.org/#/c/235356/ in OPM kilo for OSP7.

We need to backport the 2 patches in OPM/Kilo.
Comment 2 Emilien Macchi 2015-12-02 15:29:02 EST
condition of satisfaction: both patches are backported and we can see this file: https://review.openstack.org/#/c/235356/6/manifests/server/notifications.pp,cm

in puppet-neutron.
Comment 5 Ofer Blaut 2015-12-15 08:40:31 EST
tested on ospd 

22:2015-12-15 08:36:38.581 3831 INFO neutron.notifiers.nova [-] Nova event response: {u'status': u'completed', u'tag': u'287cd79b-41fd-4c80-bfcb-63e23589e34a', u'name': u'network-vif-plugged', u'server_uuid': u'5cb77bbb-153d-44f3-8f0c-1eaf1faafbcc', u'code': 200}
23:2015-12-15 08:36:39.916 3832 INFO neutron.notifiers.nova [-] Nova event response: {u'status': u'completed', u'tag': u'25db17fe-9ff9-484e-9412-43fd3dbec936', u'name': u'network-vif-plugged', u'server_uuid': u'9e0186f5-e548-498e-8823-bc17717858af', u'code': 200}

openstack-puppet-modules-2015.1.8-32.el7ost.noarch
Comment 7 errata-xmlrpc 2015-12-21 12:12:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2677

Note You need to log in before you can comment on or make changes to this bug.