Bug 1287842 - Few snapshot creation fails with pre-validation failed message on tiered volume.
Few snapshot creation fails with pre-validation failed message on tiered volume.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: bugs@gluster.org
: ZStream
Depends On: 1278798
Blocks: 1274334 1288352
  Show dependency treegraph
 
Reported: 2015-12-02 14:42 EST by Dan Lambright
Modified: 2016-06-16 09:47 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1278798
: 1288352 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:47:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-02 14:43:45 EST
REVIEW: http://review.gluster.org/12840 (cluster/tier: fix loading tier.so into glusterd) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 2 Vijay Bellur 2015-12-03 02:30:00 EST
REVIEW: http://review.gluster.org/12863 (cluster/tier: fix loading tier.so into glusterd) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 3 Vijay Bellur 2015-12-03 13:01:10 EST
COMMIT: http://review.gluster.org/12863 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 96fc7f64da2ef09e82845a7ab97574f511a9aae5
Author: N Balachandran <nbalacha@redhat.com>
Date:   Thu Dec 3 12:52:54 2015 +0530

    cluster/tier: fix loading tier.so into glusterd
    
    glusterd occasionally loads shared libraries of translators. This
    failed for tiering due to a reference to dht_methods which is defined
    as a global variable which is not necessary.
    The global variable has been removed and this is now a member of
    dht_conf and is now initialised in the *_init calls.
    
    Change-Id: Ifa0a21e3962b5cd8d9b927ef1d087d3b25312953
    BUG: 1287842
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12863
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Vijay Bellur 2015-12-28 12:01:59 EST
REVIEW: http://review.gluster.org/13104 (cluster/tier: allow queries to be interruptable) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 5 Vijay Bellur 2015-12-30 10:55:56 EST
REVIEW: http://review.gluster.org/13104 (cluster/tier: allow queries to be interruptable) posted (#2) for review on master by Joseph Fernandes
Comment 6 Vijay Bellur 2015-12-30 10:58:10 EST
REVIEW: http://review.gluster.org/13104 (cluster/tier: allow queries to be interruptable) posted (#3) for review on master by Joseph Fernandes
Comment 7 Vijay Bellur 2015-12-30 11:01:41 EST
REVIEW: http://review.gluster.org/13104 (cluster/tier: allow queries to be interruptable) posted (#4) for review on master by Joseph Fernandes
Comment 8 Vijay Bellur 2016-01-03 23:00:47 EST
REVIEW: http://review.gluster.org/13104 (cluster/tier: allow db queries to be interruptable) posted (#5) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 9 Vijay Bellur 2016-01-05 13:33:42 EST
REVIEW: http://review.gluster.org/13104 (cluster/tier: allow db queries to be interruptable) posted (#6) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 10 Vijay Bellur 2016-01-05 14:04:02 EST
REVIEW: http://review.gluster.org/13104 (cluster/tier: allow db queries to be interruptable) posted (#7) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 11 Vijay Bellur 2016-01-07 11:22:32 EST
REVIEW: http://review.gluster.org/13104 (cluster/tier: allow db queries to be interruptable) posted (#8) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 12 Vijay Bellur 2016-01-07 17:01:39 EST
COMMIT: http://review.gluster.org/13104 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit eb0d9513ece40c5d4cb7f3bae13874bbfe4fcff8
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Mon Dec 28 10:57:53 2015 -0500

    cluster/tier: allow db queries to be interruptable
    
    A query to the database may take a long time if the database
    has many entries. The tier daemon also sends IPC calls to the
    bricks which can run slowly, espcially in RHEL6. While it is
    possible to track down each such instance, the snapshot
    feature should not be affected by database operations. It requires
    no migration be underway. Therefore it is okay to pause tiering
    at any time except when DHT is moving a file.  This fix implements
    this strategy by monitoring when control passes to DHT to
    migrate a file using the GF_XATTR_FILE_MIGRATE_KEY trigger. If it
    is not, the pause operation is successful.
    
    Change-Id: I21f168b1bd424077ad5f38cf82f794060a1fabf6
    BUG: 1287842
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/13104
    Reviewed-by: Joseph Fernandes
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 13 Niels de Vos 2016-06-16 09:47:58 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.