Bug 1287849 - Multi-tenancy: Parent tenant cannot view child tenant elements
Multi-tenancy: Parent tenant cannot view child tenant elements
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.2
Assigned To: Gregg Tanzillo
Pavol Kotvan
: ZStream
Depends On: 1283309
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 15:19 EST by John Prause
Modified: 2016-02-10 10:20 EST (History)
10 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1283309
Environment:
Last Closed: 2016-02-10 10:20:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 CFME Bot 2015-12-11 17:40:04 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=9b8c9e0f1b2f81e6e424a7d4e79cef4b93f2b24d

commit 9b8c9e0f1b2f81e6e424a7d4e79cef4b93f2b24d
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Tue Dec 1 17:26:12 2015 -0500
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Fri Dec 11 12:25:28 2015 -0500

    Fixing tenant accessibility for subclassed objects
    
    - Accessibility strategy was nil for subclasses of classes listed in TENANT_ACCESS_STRATEGY hash keys
    - Added call to base_model normalize class name before lookup to ensure it will match the appropriate base class in the hash
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287849

 app/models/rbac.rb       |  2 +-
 spec/models/rbac_spec.rb | 20 ++++++++++++++++----
 2 files changed, 17 insertions(+), 5 deletions(-)
Comment 4 CFME Bot 2015-12-11 17:40:09 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=666122b0865a6091a283ec3611cde452a2088782

commit 666122b0865a6091a283ec3611cde452a2088782
Merge: f741f44 9b8c9e0
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Dec 11 17:33:27 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Dec 11 17:33:27 2015 -0500

    Merge branch 'bz-1287849-tenant-accessibility-ds' into '5.5.z'
    
    Fixing tenant accessibility for subclassed objects
    
    - Accessibility strategy was nil for subclasses of classes listed in TENANT_ACCESS_STRATEGY hash keys
    - Added call to base_model normalize class name before lookup to ensure it will match the appropriate base class in the hash
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287849
    
    This was a clean cherry-pick from https://github.com/ManageIQ/manageiq/pull/5671
    
    See merge request !610

 app/models/rbac.rb       |  2 +-
 spec/models/rbac_spec.rb | 20 ++++++++++++++++----
 2 files changed, 17 insertions(+), 5 deletions(-)
Comment 7 errata-xmlrpc 2016-02-10 10:20:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.