Bug 128785 - multiple activation keys (each with config channels) fails.
multiple activation keys (each with config channels) fails.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management (Show other bugs)
unspecified
All Linux
high Severity high
: ---
: ---
Assigned To: Mihai Ibanescu
Fanny Augustin
:
Depends On:
Blocks: 123188
  Show dependency treegraph
 
Reported: 2004-07-29 11:38 EDT by Clifford Perry
Modified: 2007-10-23 22:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:20:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Clifford Perry 2004-07-29 11:38:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
If you create two or more activation keys, each activation keys has
one or more config channels associated with it then the registration
of a system using both activation keys will fail due to conflict error
messages. The files being deployed are uniq to both keys and there is
no conflicting files to be deployed. 

This seems to be an issue with no ranking/ordering being done when
multiple activation keys (with config file channels) are used together. 

If I use a single activation key with all the config file channels
then it will work as expected (when using beta channel
up2date-4.2.29-1 rpm, fails with U2 released up2date and 4.2.16-1
version). 


Version-Release number of selected component (if applicable):
RHN Satellite 3.4 and RHN Hosted 3.4

How reproducible:
Always

Steps to Reproduce:
1. Create a config channel and put a single file into it
2. Create a second config channel and put a single different file into it
3. Create an activation key with provisioning entitlement, put the
first config channel within it. Check the Schedule deployment box at
bottom.
4. Create a second activation key with provisioning entitlement, put
the second config channel within it, again checking the schedule
deployment box. 
5. On a RHEL 3 U2 installed system run command :
# rhnreg_ks --force --activationkey=xxxxxxxxxxxxxx,zzzzzzzzzzzzzzzz

where the xxxx's and zzzz's are replaced with your two activation key
strings.


Actual Results:  https://172.16.59.210/XMLRPC

# rhnreg_ks --force
--activationkey=14adb25f2c8b5c48648642083c0c7b3b,871a603b39387f1b5cf92aff79927d4b
Error Message:
    Conflicting configuration channels for tokens
`config-channel-test-key-1' and `config-channel-test-key-2'
Error Class Code: 63
Error Class Info: Conflicting activation tokens

#

Expected Results:  It would perform a test, confirm no conflicts and
if there was a conflict go with a right to left or left to right order
of precedance for the listed keys and deploy the files as expected. 

Additional info:
Comment 1 Greg DeKoenigsberg 2004-07-29 11:43:37 EDT
So the projected fix here is to implement leftmost/firstmost ordering
of the keys as presented on the commandline.  Reassigning to Misa.
Comment 2 Mihai Ibanescu 2004-07-29 17:53:53 EDT
Fixed in HEAD and backported to the 3.4.0 branch.

Test case:

Create four configuration channels
Create two activation keys, each containing two of the four
configuration channels.
Register a system, passing xxx,yyy as the activation key (where xxx is
the first activation key and yyy is the second)
Check the registered system; should list all four channels instead of
failing.
Comment 3 Dean Samuels 2004-08-23 04:49:20 EDT
Using up2date 4.2.33-1 with RHN Satellite 3.4.  Trying to register
client with multiple activation keys, both with unique set of files
from separate config channels yields the conflict error message stated
above.  Is there a fix available?
Comment 4 Fanny Augustin 2004-10-14 15:20:55 EDT
This bug does not state whether it has been fixed or not, but it was
ON_DEV so I am assuming it is fixed.  Could you please provide a test
plan.  Thanks!
Comment 5 Mihai Ibanescu 2004-10-15 18:55:56 EDT
Test plan is in comment #2
Comment 6 Todd Warner 2004-10-21 12:23:00 EDT
QA push. {ON_DEV,QA_READY} --> ON_QA
Comment 7 Fanny Augustin 2004-10-28 11:17:58 EDT
Looks good on WebQA.
Comment 8 Fanny Augustin 2004-10-28 14:42:16 EDT
*** Bug 124975 has been marked as a duplicate of this bug. ***
Comment 9 Clay Murphy 2004-12-02 19:19:05 EST
docs complete
Comment 10 Todd Warner 2005-03-22 13:20:25 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.